Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-32215

Published: 14 July 2022

The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does not correctly handle multi-line Transfer-Encoding headers. This can lead to HTTP Request Smuggling (HRS).

Priority

Medium

Cvss 3 Severity Score

6.5

Score breakdown

Status

Package Release Status
nodejs
Launchpad, Ubuntu, Debian
kinetic Ignored
(end of life, was needs-triage)
trusty Not vulnerable
(code not present)
upstream Needs triage

bionic Not vulnerable
(code not present)
focal Not vulnerable
(code not present)
impish Ignored
(end of life)
xenial Not vulnerable
(code not present)
lunar Not vulnerable
(18.13.0+dfsg1-1ubuntu2)
mantic Not vulnerable
(18.13.0+dfsg1-1ubuntu2)
jammy
Released (12.22.9~dfsg-1ubuntu3.2)

Severity score breakdown

Parameter Value
Base score 6.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality Low
Integrity impact Low
Availability impact None
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N