Your submission was sent successfully! Close

CVE-2022-31620

Published: 25 May 2022

In libjpeg before 1.64, BitStream<false>::Get in bitstream.hpp has an assertion failure that may cause denial of service. This is related to out-of-bounds array access during arithmetically coded lossless scan or arithmetically coded sequential scan.

Priority

Low

CVSS 3 base score: 6.5

Status

Package Release Status
libjpeg
Launchpad, Ubuntu, Debian
focal Needs triage

impish Needs triage

jammy Needs triage

upstream Needs triage

libjpeg-turbo
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(code not present)
focal Not vulnerable
(code not present)
impish Not vulnerable
(code not present)
jammy Not vulnerable
(code not present)
trusty Not vulnerable
(code not present)
upstream Needs triage

xenial Not vulnerable
(code not present)
libjpeg6b
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(code not present)
focal Not vulnerable
(code not present)
impish Not vulnerable
(code not present)
jammy Not vulnerable
(code not present)
trusty Not vulnerable
(code not present)
upstream Not vulnerable
(code not present)
xenial Ignored
(end of standard support, was not-affected [code not present])
libjpeg9
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(code not present)
focal Not vulnerable
(code not present)
impish Not vulnerable
(code not present)
jammy Not vulnerable
(code not present)
trusty Does not exist

upstream Needs triage

xenial Ignored
(end of standard support)