Your submission was sent successfully! Close

CVE-2022-31607

Published: 2 August 2022

NVIDIA GPU Display Driver for Linux contains a vulnerability in the kernel mode layer (nvidia.ko), where a local user with basic capabilities can cause improper input validation, which may lead to denial of service, escalation of privileges, data tampering, and limited information disclosure.

From the Ubuntu security team

Le Wu discovered that the NVIDIA graphics drivers did not properly perform input validation in some situations. A local user could use this to cause a denial of service or possibly execute arbitrary code.

Notes

AuthorNote
mdeslaur
some binary drivers are no longer support by NVidia, so they
are marked as ignored here
Priority

High

Status

Package Release Status
nvidia-graphics-drivers-304
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Ignored

nvidia-graphics-drivers-304-updates
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Not vulnerable
(superseded)
nvidia-graphics-drivers-340
Launchpad, Ubuntu, Debian
bionic Ignored

focal Ignored

jammy Not vulnerable
(superseded)
trusty Does not exist

upstream Needs triage

xenial Ignored

nvidia-graphics-drivers-340-updates
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(superseded)
focal Does not exist

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Not vulnerable
(superseded)
nvidia-graphics-drivers-352
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(superseded)
focal Does not exist

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Not vulnerable
(superseded)
nvidia-graphics-drivers-352-updates
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(superseded)
focal Does not exist

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Not vulnerable
(superseded)
nvidia-graphics-drivers-361
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(superseded)
focal Does not exist

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Not vulnerable
(superseded)
nvidia-graphics-drivers-367
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(superseded)
focal Does not exist

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Not vulnerable
(superseded)
nvidia-graphics-drivers-375
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(superseded)
focal Does not exist

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Not vulnerable
(superseded)
nvidia-graphics-drivers-384
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(superseded)
focal Does not exist

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Ignored
(end of standard support)
nvidia-graphics-drivers-390
Launchpad, Ubuntu, Debian
bionic
Released (390.154-0ubuntu0.18.04.1)
focal
Released (390.154-0ubuntu0.20.04.1)
jammy
Released (390.154-0ubuntu0.22.04.1)
trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-418-server
Launchpad, Ubuntu, Debian
bionic Ignored

focal Ignored

jammy Ignored

trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-430
Launchpad, Ubuntu, Debian
bionic Ignored

focal Ignored

jammy Ignored

trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-435
Launchpad, Ubuntu, Debian
bionic Ignored

focal Ignored

jammy Ignored

trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-440
Launchpad, Ubuntu, Debian
bionic Ignored

focal Ignored

jammy Ignored

trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-440-server
Launchpad, Ubuntu, Debian
bionic Ignored

focal Ignored

jammy Ignored

trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-450
Launchpad, Ubuntu, Debian
bionic Ignored

focal Ignored

jammy Ignored

trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-450-server
Launchpad, Ubuntu, Debian
bionic
Released (450.203.03-0ubuntu0.18.04.1)
focal
Released (450.203.03-0ubuntu0.20.04.1)
jammy
Released (450.203.03-0ubuntu0.22.04.1)
trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-455
Launchpad, Ubuntu, Debian
bionic Ignored

focal Ignored

jammy Ignored

trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-460
Launchpad, Ubuntu, Debian
bionic Ignored

focal Ignored

jammy Ignored

trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-460-server
Launchpad, Ubuntu, Debian
bionic Ignored

focal Ignored

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-470
Launchpad, Ubuntu, Debian
bionic
Released (470.141.03-0ubuntu0.18.04.1)
focal
Released (470.141.03-0ubuntu0.20.04.1)
jammy
Released (470.141.03-0ubuntu0.22.04.1)
trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-470-server
Launchpad, Ubuntu, Debian
bionic
Released (470.141.03-0ubuntu0.18.04.1)
focal
Released (470.141.03-0ubuntu0.20.04.1)
jammy
Released (470.141.03-0ubuntu0.22.04.1)
trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-495
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(superseded)
focal Not vulnerable
(superseded)
jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-510
Launchpad, Ubuntu, Debian
bionic
Released (510.85.02-0ubuntu0.18.04.1)
focal
Released (510.85.02-0ubuntu0.20.04.1)
jammy
Released (510.85.02-0ubuntu0.22.04.1)
trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-510-server
Launchpad, Ubuntu, Debian
bionic
Released (510.85.02-0ubuntu0.18.04.1)
focal
Released (510.85.02-0ubuntu0.20.04.1)
jammy
Released (510.85.02-0ubuntu0.22.04.1)
trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-515
Launchpad, Ubuntu, Debian
bionic
Released (515.65.01-0ubuntu0.18.04.1)
focal
Released (515.65.01-0ubuntu0.20.04.1)
jammy
Released (515.65.01-0ubuntu0.22.04.1)
trusty Does not exist

upstream Needs triage

xenial Does not exist

nvidia-graphics-drivers-515-server
Launchpad, Ubuntu, Debian
bionic
Released (515.65.01-0ubuntu0.18.04.1)
focal
Released (515.65.01-0ubuntu0.20.04.1)
jammy
Released (515.65.01-0ubuntu0.22.04.1)
trusty Does not exist

upstream Needs triage

xenial Does not exist