Your submission was sent successfully! Close

CVE-2022-27774

Published: 27 April 2022

An insufficiently protected credentials vulnerability exists in curl 4.9 to and include curl 7.82.0 are affected that could allow an attacker to extract credentials when follows HTTP(S) redirects is used with authentication could leak credentials to other services that exist on different protocols or port numbers.

Priority

Medium

CVSS 3 base score: 5.7

Status

Package Release Status
curl
Launchpad, Ubuntu, Debian
bionic
Released (7.58.0-2ubuntu3.17)
focal
Released (7.68.0-1ubuntu2.10)
impish
Released (7.74.0-1.3ubuntu2.1)
jammy
Released (7.81.0-1ubuntu1.1)
trusty Ignored
(regressions likely)
upstream
Released (7.83.0)
xenial Ignored
(regressions likely)