Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-27664

Published: 6 September 2022

In net/http in Go before 1.18.6 and 1.19.x before 1.19.1, attackers can cause a denial of service because an HTTP/2 connection can hang during closing if shutdown were preempted by a fatal error.

Notes

AuthorNote
mdeslaur
Packages built using golang need to be rebuilt once the
vulnerability has been fixed. This CVE entry does not
list packages that need rebuilding outside of the main
repository or the Ubuntu variants with PPA overlays.
alexmurray
google-guest-agent contains a vendored copy of golang-golang-x-net
mdeslaur
google-guest-agent doesn't start a http server except in tests
containerd does not listen on an HTTP/2 endpoint, so not
vulnerable.

Priority

Medium

Cvss 3 Severity Score

7.5

Score breakdown

Status

Package Release Status
containerd
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Not vulnerable

jammy Not vulnerable

lunar Ignored
(end of life, was needs-triage)
mantic Not vulnerable

trusty Ignored
(end of standard support)
upstream Needs triage

xenial Not vulnerable

golang
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

jammy Does not exist

trusty Ignored
(end of standard support)
upstream Needs triage

xenial Ignored
(end of standard support)
golang-1.10
Launchpad, Ubuntu, Debian
bionic Needed

focal Does not exist

jammy Does not exist

trusty Needed

upstream Needs triage

xenial Needed

golang-1.13
Launchpad, Ubuntu, Debian
bionic
Released (1.13.8-1ubuntu1~18.04.4+esm1)
Available with Ubuntu Pro
focal
Released (1.13.8-1ubuntu1.2)
jammy
Released (1.13.8-1ubuntu2.22.04.2)
kinetic Ignored
(end of life, was needs-triage)
lunar Does not exist

mantic Does not exist

trusty Ignored
(end of standard support)
upstream Needs triage

xenial
Released (1.13.8-1ubuntu1~16.04.3+esm3)
Available with Ubuntu Pro
golang-1.14
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Needed

jammy Does not exist

trusty Ignored
(end of standard support)
upstream Needs triage

xenial Ignored
(end of standard support)
golang-1.16
Launchpad, Ubuntu, Debian
bionic
Released (1.16.2-0ubuntu1~18.04.2+esm1)
Available with Ubuntu Pro
focal
Released (1.16.2-0ubuntu1~20.04.1)
jammy Does not exist

trusty Ignored
(end of standard support)
upstream Needs triage

xenial Ignored
(end of standard support)
golang-1.17
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

jammy Needed

trusty Ignored
(end of standard support)
upstream Needs triage

xenial Ignored
(end of standard support)
golang-1.18
Launchpad, Ubuntu, Debian
bionic
Released (1.18.1-1ubuntu1~18.04.4)
focal
Released (1.18.1-1ubuntu1~20.04.2)
jammy
Released (1.18.1-1ubuntu1.1)
kinetic Does not exist

lunar Does not exist

mantic Does not exist

trusty Ignored
(end of standard support)
upstream Needs triage

xenial
Released (1.18.1-1ubuntu1~16.04.4)
Available with Ubuntu Pro
golang-1.6
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

jammy Does not exist

trusty Ignored
(end of standard support)
upstream Needs triage

xenial Needed

golang-1.8
Launchpad, Ubuntu, Debian
bionic Needed

focal Does not exist

jammy Does not exist

trusty Ignored
(end of standard support)
upstream Needs triage

xenial Ignored
(end of standard support)
golang-1.9
Launchpad, Ubuntu, Debian
bionic Needed

focal Does not exist

jammy Does not exist

trusty Ignored
(end of standard support)
upstream Needs triage

xenial Ignored
(end of standard support)
golang-golang-x-net
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

jammy Needed

lunar Not vulnerable
(0.7.0+dfsg-1)
mantic Not vulnerable
(0.10.0-1)
trusty Does not exist

upstream
Released (1:0.0+git20221012.0b7e1fb+dfsg-1)
xenial Does not exist

Patches:
upstream: https://github.com/golang/net/commit/f3363e06e74cdc304618bf31d898b78590103527
golang-golang-x-net-dev
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Needs triage

jammy Does not exist

lunar Does not exist

mantic Does not exist

trusty Does not exist

upstream Needs triage

xenial Needs triage

google-guest-agent
Launchpad, Ubuntu, Debian
bionic Needs triage

focal
Released (20231004.02-0ubuntu1~20.04.3)
jammy
Released (20231004.02-0ubuntu1~22.04.3)
lunar Ignored
(end of life, was needs-triage)
mantic
Released (20230426.00-0ubuntu2)
trusty Does not exist

upstream Needs triage

xenial Needs triage

Severity score breakdown

Parameter Value
Base score 7.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H