Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-27135

Published: 25 April 2022

xpdf 4.03 has heap buffer overflow in the function readXRefTable located in XRef.cc. An attacker can exploit this bug to cause a Denial of Service (Segmentation fault) or other unspecified effects by sending a crafted PDF file to the pdftoppm binary.

Notes

AuthorNote
jdstrand
xpdf in koffice is 2.0
mdeslaur
no indication poppler is vulnerable to this CVE
ebarretto
xpdf in Debian uses poppler, which is not affected or fixed

Priority

Medium

Cvss 3 Severity Score

5.5

Score breakdown

Status

Package Release Status
ipe
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Needs triage

impish Ignored
(end of life)
jammy Needs triage

kinetic Ignored
(end of life, was needs-triage)
lunar Ignored
(end of life, was needs-triage)
mantic Ignored
(end of life, was needs-triage)
noble Needs triage

trusty Does not exist

upstream Needs triage

xenial Needs triage

poppler
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Not vulnerable

impish Not vulnerable

jammy Not vulnerable

kinetic Not vulnerable

lunar Not vulnerable

mantic Not vulnerable

noble Not vulnerable

trusty Does not exist

upstream Needs triage

xenial Not vulnerable

xpdf
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(code not present)
focal Does not exist

impish Ignored
(end of life)
jammy Not vulnerable
(code not present)
kinetic Not vulnerable
(code not present)
lunar Not vulnerable
(code not present)
mantic Not vulnerable
(code not present)
noble Not vulnerable
(code not present)
trusty Does not exist

upstream Not vulnerable
(debian: Debian uses poppler, which is not affected)
xenial Not vulnerable
(code not present)

Severity score breakdown

Parameter Value
Base score 5.5
Attack vector Local
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H