Your submission was sent successfully! Close

You have successfully unsubscribed! Close

CVE-2022-26387

Published: 9 March 2022

When installing an add-on, Firefox verified the signature before prompting the user; but while the user was confirming the prompt, the underlying add-on file could have been modified and Firefox would not have noticed. This vulnerability affects Firefox < 98, Firefox ESR < 91.7, and Thunderbird < 91.7.

Notes

AuthorNote
tyhicks
mozjs contains a copy of the SpiderMonkey JavaScript engine
Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
bionic
Released (98.0+build3-0ubuntu0.18.04.2)
focal
Released (98.0+build3-0ubuntu0.20.04.2)
impish
Released (98.0+build3-0ubuntu0.21.10.2)
jammy
Released (1:1snap1-0ubuntu1)
kinetic
Released (1:1snap1-0ubuntu1)
trusty Does not exist

upstream
Released (98)
xenial Needed

firefox-esr
Launchpad, Ubuntu, Debian
trusty Ignored
(out of standard support)
upstream
Released (91.7.0esr-1)
xenial Ignored
(out of standard support)
mozjs38
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

mozjs52
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Needs triage

impish Does not exist

jammy Does not exist

kinetic Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

mozjs68
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Needs triage

impish Does not exist

jammy Does not exist

kinetic Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

mozjs78
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

impish Ignored
(reached end-of-life)
jammy Needs triage

kinetic Needs triage

trusty Does not exist

upstream Needs triage

xenial Does not exist

thunderbird
Launchpad, Ubuntu, Debian
bionic
Released (1:91.7.0+build2-0ubuntu0.18.04.1)
focal
Released (1:91.7.0+build2-0ubuntu0.20.04.1)
impish
Released (1:91.7.0+build2-0ubuntu0.21.10.1)
jammy
Released (1:91.7.0+build2-0ubuntu1)
kinetic
Released (1:91.7.0+build2-0ubuntu1)
trusty Does not exist

upstream
Released (91.7)
xenial Needed