Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-24834

Published: 13 July 2023

Redis is an in-memory database that persists on disk. A specially crafted Lua script executing in Redis can trigger a heap overflow in the cjson library, and result with heap corruption and potentially remote code execution. The problem exists in all versions of Redis with Lua scripting support, starting from 2.6, and affects only authenticated and authorized users. The problem is fixed in versions 7.0.12, 6.2.13, and 6.0.20.

Priority

Medium

Cvss 3 Severity Score

8.8

Score breakdown

Status

Package Release Status
redis
Launchpad, Ubuntu, Debian
lunar Ignored
(end of life, was needs-triage)
upstream
Released (5:7.0.12-1)
kinetic Ignored
(end of life, was needs-triage)
mantic Needs triage

bionic
Released (5:4.0.9-1ubuntu0.2+esm4)
Available with Ubuntu Pro
focal
Released (5:5.0.7-2ubuntu0.1+esm2)
Available with Ubuntu Pro
jammy
Released (5:6.0.16-1ubuntu1+esm1)
Available with Ubuntu Pro
trusty
Released (2:2.8.4-2ubuntu0.2+esm3)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
xenial
Released (2:3.0.6-1ubuntu0.4+esm2)
Available with Ubuntu Pro

Severity score breakdown

Parameter Value
Base score 8.8
Attack vector Network
Attack complexity Low
Privileges required Low
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H