Your submission was sent successfully! Close

CVE-2022-24761

Published: 17 March 2022

Waitress is a Web Server Gateway Interface server for Python 2 and 3. When using Waitress versions 2.1.0 and prior behind a proxy that does not properly validate the incoming HTTP request matches the RFC7230 standard, Waitress and the frontend proxy may disagree on where one request starts and where it ends. This would allow requests to be smuggled via the front-end proxy to waitress and later behavior. There are two classes of vulnerability that may lead to request smuggling that are addressed by this advisory: The use of Python's `int()` to parse strings into integers, leading to `+10` to be parsed as `10`, or `0x01` to be parsed as `1`, where as the standard specifies that the string should contain only digits or hex digits; and Waitress does not support chunk extensions, however it was discarding them without validating that they did not contain illegal characters. This vulnerability has been patched in Waitress 2.1.1. A workaround is available. When deploying a proxy in front of waitress, turning on any and all functionality to make sure that the request matches the RFC7230 standard. Certain proxy servers may not have this functionality though and users are encouraged to upgrade to the latest version of waitress instead.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
waitress
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(code not present)
focal
Released (1.4.1-1ubuntu0.1)
impish
Released (1.4.4-1.1ubuntu0.1)
jammy
Released (1.4.4-1.1ubuntu1)
trusty Ignored
(out of standard support)
upstream Needs triage

xenial Not vulnerable
(code not present)