Your submission was sent successfully! Close

CVE-2022-24407

Published: 22 February 2022

In Cyrus SASL 2.1.17 through 2.1.27 before 2.1.28, plugins/sql.c does not escape the password for a SQL INSERT or UPDATE statement.

Priority

High

CVSS 3 base score: 8.8

Status

Package Release Status
cyrus-sasl2
Launchpad, Ubuntu, Debian
bionic
Released (2.1.27~101-g0780600+dfsg-3ubuntu2.4)
focal
Released (2.1.27+dfsg-2ubuntu0.1)
impish
Released (2.1.27+dfsg-2.1ubuntu0.1)
jammy
Released (2.1.27+dfsg2-3ubuntu1)
trusty
Released (2.1.25.dfsg1-17ubuntu0.1~esm2)
upstream
Released (2.1.28)
xenial
Released (2.1.26.dfsg1-14ubuntu0.2+esm1)
Patches:
upstream: https://github.com/cyrusimap/cyrus-sasl/commit/2d2e97b0eb53fa7f87a3bf1529d8f712dd954480