Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-23493

Published: 9 December 2022

xrdp is an open source project which provides a graphical login to remote machines using Microsoft Remote Desktop Protocol (RDP). xrdp < v0.9.21 contain a Out of Bound Read in xrdp_mm_trans_process_drdynvc_channel_close() function. There are no known workarounds for this issue. Users are advised to upgrade.

Priority

Medium

Cvss 3 Severity Score

9.1

Score breakdown

Status

Package Release Status
xrdp
Launchpad, Ubuntu, Debian
kinetic Ignored
(end of life, was needs-triage)
bionic Not vulnerable
(code not present)
lunar Not vulnerable
(0.9.21.1-1)
mantic Not vulnerable
(0.9.21.1-1)
trusty Not vulnerable
(code not present)
upstream
Released (0.9.21)
xenial Not vulnerable
(code not present)
focal
Released (0.9.12-1ubuntu0.1+esm1)
Available with Ubuntu Pro
jammy
Released (0.9.17-2ubuntu2+esm1)
Available with Ubuntu Pro

Severity score breakdown

Parameter Value
Base score 9.1
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H