Your submission was sent successfully! Close

You have successfully unsubscribed! Close

CVE-2022-22763

Published: 9 February 2022

When a worker is shutdown, it was possible to cause script to run late in the lifecycle, at a point after where it should not be possible. This vulnerability affects Firefox < 96, Thunderbird < 91.6, and Firefox ESR < 91.6.

Notes

AuthorNote
tyhicks
mozjs contains a copy of the SpiderMonkey JavaScript engine
mdeslaur
looks like this only affected firefox esr and not regular
firefox, marking as not-affected

Priority

Medium

Cvss 3 Severity Score

8.8

Score breakdown

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Not vulnerable

impish Not vulnerable

jammy Not vulnerable

kinetic Not vulnerable

trusty Does not exist

upstream Needs triage

xenial Needed

mozjs38
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

mozjs52
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Needs triage

impish Does not exist

jammy Does not exist

kinetic Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

mozjs68
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Needs triage

impish Does not exist

jammy Does not exist

kinetic Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

mozjs78
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

impish Ignored
(reached end-of-life)
jammy Needs triage

kinetic Needs triage

trusty Does not exist

upstream Needs triage

xenial Does not exist

thunderbird
Launchpad, Ubuntu, Debian
bionic
Released (1:91.7.0+build2-0ubuntu0.18.04.1)
focal
Released (1:91.7.0+build2-0ubuntu0.20.04.1)
impish
Released (1:91.7.0+build2-0ubuntu0.21.10.1)
jammy
Released (1:91.6.1+build1-0ubuntu1)
kinetic
Released (1:91.6.1+build1-0ubuntu1)
trusty Does not exist

upstream
Released (91.6)
xenial Needed

Severity score breakdown

Parameter Value
Base score 8.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H