Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-2121

Published: 24 June 2022

OFFIS DCMTK's (All versions prior to 3.6.7) has a NULL pointer dereference vulnerability while processing DICOM files, which may result in a denial-of-service condition.

Priority

Low

Cvss 3 Severity Score

6.5

Score breakdown

Status

Package Release Status
dcmtk
Launchpad, Ubuntu, Debian
bionic
Released (3.6.2-3ubuntu0.1~esm1)
Available with Ubuntu Pro
focal
Released (3.6.4-2.1ubuntu0.1~esm1)
Available with Ubuntu Pro
impish Ignored
(end of life)
jammy
Released (3.6.6-5ubuntu0.1~esm1)
Available with Ubuntu Pro
kinetic Not vulnerable
(3.6.7-6)
lunar Ignored
(end of life, was needs-triage)
mantic Needs triage

noble Needs triage

trusty Ignored
(end of standard support, was needs-triage)
upstream Needs triage

xenial
Released (3.6.1~20150924-5ubuntu0.1~esm1)
Available with Ubuntu Pro
Patches:
upstream: https://github.com/DCMTK/dcmtk/commit/3e996a2749a9355c9b680fa464ecfd9ab9ff567f

Severity score breakdown

Parameter Value
Base score 6.5
Attack vector Adjacent
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H