Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2021-44143

Published: 22 November 2021

A flaw was found in mbsync in isync 1.4.0 through 1.4.3. Due to an unchecked condition, a malicious or compromised IMAP server could use a crafted mail message that lacks headers (i.e., one that starts with an empty line) to provoke a heap overflow, which could conceivably be exploited for remote code execution.

Notes

AuthorNote
seth-arnold
I can't find a fix for this in the source browser; I'm marking
jammy as 'needed' and others as 'not-affected' based on the version number,
but I distrust the upper end of the '1.4.0 through 1.4.3' range given in
the CVE description. I suspect "unfixed" is the more correct upper range.

Priority

Medium

Cvss 3 Severity Score

9.8

Score breakdown

Status

Package Release Status
isync
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Not vulnerable

hirsute Not vulnerable

impish Not vulnerable

jammy Needed

kinetic Ignored
(end of life, was needed)
lunar Ignored
(end of life, was needed)
mantic Needed

noble Needed

trusty Ignored
(end of standard support)
upstream Needed

xenial Needs triage

Severity score breakdown

Parameter Value
Base score 9.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H