Your submission was sent successfully! Close

CVE-2021-4206

Published: 29 April 2022

A flaw was found in the QXL display device emulation in QEMU. An integer overflow in the cursor_alloc() function can lead to the allocation of a small cursor object followed by a subsequent heap-based buffer overflow. This flaw allows a malicious privileged guest user to crash the QEMU process on the host or potentially execute arbitrary code within the context of the QEMU process.

Priority

Medium

CVSS 3 base score: 8.2

Status

Package Release Status
qemu
Launchpad, Ubuntu, Debian
bionic
Released (1:2.11+dfsg-1ubuntu7.40)
focal
Released (1:4.2-3ubuntu6.23)
impish
Released (1:6.0+dfsg-2expubuntu1.3)
jammy
Released (1:6.2+dfsg-2ubuntu6.2)
trusty Needs triage

upstream Needs triage

xenial Needs triage

Patches:
upstream: https://git.qemu.org/?p=qemu.git;a=commit;h=fa892e9abb728e76afcf27323ab29c57fb0fe7aa