Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2021-41054

Published: 13 September 2021

tftpd_file.c in atftp through 0.7.4 has a buffer overflow because buffer-size handling does not properly consider the combination of data, OACK, and other options.

Priority

Medium

Cvss 3 Severity Score

7.5

Score breakdown

Status

Package Release Status
atftp
Launchpad, Ubuntu, Debian
trusty Does not exist

hirsute Ignored
(end of life)
kinetic Ignored
(end of life, was needs-triage)
bionic
Released (0.7.git20120829-3.1~0.18.04.1+esm1)
Available with Ubuntu Pro
focal
Released (0.7.git20120829-3.1ubuntu0.1)
upstream Not vulnerable

xenial
Released (0.7.git20120829-3.1~0.16.04.1+esm1)
Available with Ubuntu Pro
jammy Not vulnerable
(0.7.git20210915-4)
impish Ignored
(end of life)
lunar Not vulnerable
(0.8.0-3)

Severity score breakdown

Parameter Value
Base score 7.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H