CVE-2021-40346

Published: 07 September 2021

An integer overflow exists in HAProxy 2.0 through 2.5 in htx_add_header that can be exploited to perform an HTTP request smuggling attack, allowing an attacker to bypass all configured http-request HAProxy ACLs and possibly other ACLs.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
haproxy
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo)
Released (2.2.9-1ubuntu0.2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.0.13-2ubuntu0.3)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(code not present)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist