Your submission was sent successfully! Close

CVE-2021-3962

Published: 19 November 2021

A flaw was found in ImageMagick where it did not properly sanitize certain input before using it to invoke convert processes. This flaw allows an attacker to create a specially crafted image that leads to a use-after-free vulnerability when processed by ImageMagick. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
imagemagick
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(code not present, 7.x only)
focal Not vulnerable
(code not present, 7.x only)
hirsute Not vulnerable
(code not present, 7.x only)
impish Not vulnerable
(code not present, 7.x only)
jammy Not vulnerable
(code not present, 7.x only)
trusty Ignored
(out of standard support)
upstream Needs triage

xenial Not vulnerable
(code not present, 7.x only)
Patches:
upstream: https://github.com/ImageMagick/ImageMagick/commit/82775af03bbb10a0a1d0e15c0156c75673b4525e