Your submission was sent successfully! Close

CVE-2021-37594

Published: 30 July 2021

In FreeRDP before 2.4.0 on Windows, wf_cliprdr_server_file_contents_request in client/Windows/wf_cliprdr.c has missing input checks for a FILECONTENTS_SIZE File Contents Request PDU.

Priority

Low

CVSS 3 base score: 9.8

Status

Package Release Status
freerdp2
Launchpad, Ubuntu, Debian
Upstream Not vulnerable
(debian: Windows-specific)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(windows-specific)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(windows-specific)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(windows-specific)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(windows-specific)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(out of standard support)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/FreeRDP/FreeRDP/commit/0d79670a28c0ab049af08613621aa0c267f977e9