Your submission was sent successfully! Close

CVE-2021-3677

Published: 12 August 2021

A flaw was found in postgresql. A purpose-crafted query can read arbitrary bytes of server memory. In the default configuration, any authenticated database user can complete this attack at will. The attack does not require the ability to create objects. If server settings include max_worker_processes=0, the known versions of this attack are infeasible. However, undiscovered variants of the attack may be independent of that setting.

Notes

AuthorNote
leosilva
PostgreSQL 9.3 is end of life upstream, and no updates are
are available. Marking as deferred in -esm-main releases.
Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
postgresql-10
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

trusty Does not exist

upstream Not vulnerable

xenial Does not exist

postgresql-12
Launchpad, Ubuntu, Debian
bionic Does not exist

focal
Released (12.8-0ubuntu0.20.04.1)
hirsute Does not exist

impish Does not exist

jammy Does not exist

trusty Does not exist

upstream
Released (12.8)
xenial Does not exist

postgresql-13
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

hirsute
Released (13.4-0ubuntu0.21.04.1)
impish
Released (13.4-1)
jammy Does not exist

trusty Does not exist

upstream
Released (13.4)
xenial Does not exist

postgresql-9.1
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

trusty Does not exist

upstream Not vulnerable

xenial Does not exist

postgresql-9.3
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

trusty Not vulnerable

upstream Not vulnerable

xenial Does not exist

postgresql-9.5
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

trusty Does not exist

upstream Not vulnerable

xenial Not vulnerable