Your submission was sent successfully! Close

CVE-2021-3656

Published: 16 August 2021

A flaw was found in the KVM's AMD code for supporting SVM nested virtualization. The flaw occurs when processing the VMCB (virtual machine control block) provided by the L1 guest to spawn/handle a nested guest (L2). Due to improper validation of the "virt_ext" field, this issue could allow a malicious L1 to disable both VMLOAD/VMSAVE intercepts and VLS (Virtual VMLOAD/VMSAVE) for the L2 guest. As a result, the L2 guest would be allowed to read/write physical pages of the host, resulting in a crash of the entire system, leak of sensitive data or potential guest-to-host escape.

From the Ubuntu security team

Maxim Levitsky and Paolo Bonzini discovered that the KVM hypervisor implementation for AMD processors in the Linux kernel allowed a guest VM to disable restrictions on VMLOAD/VMSAVE in a nested guest. An attacker in a guest VM could use this to read or write portions of the host's physical memory.

Mitigation

Disable nested virtualisation when loading the KVM AMD module:
   modprobe kvm_amd nested=0
Priority

High

CVSS 3 base score: 8.8

Status

Package Release Status
linux-azure-5.8
Launchpad, Ubuntu, Debian
focal
Released (5.8.0-1041.44~20.04.1)
bionic Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

upstream
Released (5.14~rc7)
impish Does not exist

jammy Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
bionic Ignored
(replaced by linux-hwe-5.4)
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial
Released (4.15.0-156.163~16.04.1)
impish Does not exist

upstream
Released (5.14~rc7)
jammy Does not exist

linux-hwe-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

bionic
Released (5.4.0-84.94~18.04.1)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-hwe-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

focal Ignored
(was pending [5.8.0-67.75] now end-of-life)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-hwe-edge
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-hwe-5.4)
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Ignored
(superseded by linux-hwe)
impish Does not exist

upstream
Released (5.14~rc7)
jammy Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

hirsute Does not exist

trusty Not vulnerable
(4.4.0-13.29~14.04.1)
xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
jammy Does not exist

linux-aws-5.0
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-aws-5.3)
focal Does not exist

hirsute Does not exist

upstream
Released (5.14~rc7)
trusty Does not exist

xenial Does not exist

impish Does not exist

jammy Does not exist

linux-aws-5.3
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-aws-5.4)
focal Does not exist

hirsute Does not exist

upstream
Released (5.14~rc7)
trusty Does not exist

xenial Does not exist

impish Does not exist

jammy Does not exist

linux-aws-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

upstream
Released (5.14~rc7)
trusty Does not exist

xenial Does not exist

impish Does not exist

bionic
Released (5.4.0-1056.59~18.04.1)
jammy Does not exist

linux-aws-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

focal Ignored
(was needs-triage now end-of-life)
upstream
Released (5.14~rc7)
trusty Does not exist

xenial Does not exist

impish Does not exist

jammy Does not exist

linux-aws-hwe
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

hirsute Does not exist

upstream
Released (5.14~rc7)
trusty Does not exist

xenial
Released (4.15.0-1111.118~16.04.1)
impish Does not exist

jammy Does not exist

linux-azure
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-azure-5.3)
upstream
Released (5.14~rc7)
trusty
Released (4.15.0-1123.136~14.04.1)
xenial
Released (4.15.0-1123.136~16.04.1)
impish Not vulnerable
(5.13.0-1004.5)
focal
Released (5.4.0-1058.60)
hirsute
Released (5.11.0-1015.16)
jammy Not vulnerable
(5.13.0-1006.7)
linux-azure-4.15
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

upstream
Released (5.14~rc7)
trusty Does not exist

xenial Does not exist

impish Does not exist

bionic
Released (4.15.0-1123.136)
jammy Does not exist

linux-azure-5.3
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-azure-5.4)
focal Does not exist

hirsute Does not exist

upstream
Released (5.14~rc7)
trusty Does not exist

xenial Does not exist

impish Does not exist

jammy Does not exist

linux-azure-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

upstream
Released (5.14~rc7)
trusty Does not exist

xenial Does not exist

impish Does not exist

bionic
Released (5.4.0-1058.60~18.04.1)
jammy Does not exist

linux-bluefield
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
focal
Released (5.4.0-1019.22)
jammy Does not exist

linux-dell300x
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
bionic
Released (4.15.0-1027.32)
jammy Does not exist

linux-azure-edge
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-azure-5.3)
focal Does not exist

hirsute Does not exist

upstream
Released (5.14~rc7)
trusty Does not exist

xenial Does not exist

impish Does not exist

jammy Does not exist

linux-gcp
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-gcp-5.3)
trusty Does not exist

xenial
Released (4.15.0-1108.122~16.04.1)
impish Not vulnerable
(5.13.0-1003.4)
upstream
Released (5.14~rc7)
focal
Released (5.4.0-1052.56)
hirsute
Released (5.11.0-1018.20)
jammy Not vulnerable
(5.13.0-1005.6)
linux-gcp-4.15
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
bionic
Released (4.15.0-1108.122)
jammy Does not exist

linux-gcp-5.3
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-gcp-5.4)
focal Does not exist

hirsute Does not exist

upstream
Released (5.14~rc7)
trusty Does not exist

xenial Does not exist

impish Does not exist

jammy Does not exist

linux-gcp-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
bionic
Released (5.4.0-1052.56~18.04.1)
jammy Does not exist

linux-gcp-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

focal Ignored
(was needs-triage now end-of-life)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-gcp-edge
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-gcp-5.3)
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
jammy Does not exist

linux-gke
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

trusty Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
focal
Released (5.4.0-1052.55)
xenial Ignored
(reached end of standard support)
jammy Not vulnerable
(5.15.0-1002.2)
linux-gke-4.15
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

bionic Ignored
(was needs-triage now end-of-life)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-gke-5.0
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

bionic Ignored
(was needs-triage now end-of-life)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-gke-5.3
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

bionic Ignored
(was needs-triage now end-of-life)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-gke-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
bionic
Released (5.4.0-1052.55~18.04.1)
jammy Does not exist

linux-gkeop
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
focal
Released (5.4.0-1023.24)
jammy Needs triage

linux-gkeop-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
bionic
Released (5.4.0-1023.24~18.04.1)
jammy Does not exist

linux-oracle-5.0
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-oracle-5.3)
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
jammy Does not exist

linux-oracle-5.3
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-oracle-5.4)
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
jammy Does not exist

linux-oracle-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
bionic
Released (5.4.0-1054.58~18.04.1)
jammy Does not exist

linux-oracle-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

focal Ignored
(was needs-triage now end-of-life)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-oem
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

trusty Does not exist

impish Does not exist

bionic Ignored
(was needs-triage now end-of-life)
upstream
Released (5.14~rc7)
xenial Ignored
(superseded by linux-hwe)
jammy Does not exist

linux-oem-5.6
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

focal Ignored
(was needs-triage now end-of-life)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-oem-5.10
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
focal
Released (5.10.0-1045.47)
jammy Does not exist

linux-oem-osp1
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

bionic Ignored
(was needs-triage now end-of-life)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-raspi
Launchpad, Ubuntu, Debian
bionic Does not exist

trusty Does not exist

xenial Does not exist

impish Not vulnerable
(AMD processors only)
focal Not vulnerable
(AMD processors only)
upstream
Released (5.14~rc7)
hirsute
Released (5.11.0-1017.18)
jammy Not vulnerable
(AMD processors only)
linux-raspi2
Launchpad, Ubuntu, Debian
focal Not vulnerable
(AMD processors only)
hirsute Does not exist

trusty Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
xenial Not vulnerable
(AMD processors only)
bionic Not vulnerable
(AMD processors only)
jammy Does not exist

linux-raspi2-5.3
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
bionic Not vulnerable
(AMD processors only)
jammy Does not exist

linux-raspi-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
bionic Not vulnerable
(AMD processors only)
jammy Does not exist

linux-riscv
Launchpad, Ubuntu, Debian
bionic Does not exist

trusty Does not exist

xenial Does not exist

impish Not vulnerable
(AMD processors only)
focal Not vulnerable
(AMD processors only)
upstream
Released (5.14~rc7)
hirsute
Released (5.11.0-1018.19)
jammy Not vulnerable
(AMD processors only)
linux-riscv-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

focal Not vulnerable
(AMD processors only)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-snapdragon
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

trusty Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
bionic
Released (4.15.0-1112.121)
xenial Not vulnerable
(AMD processors only)
jammy Does not exist

linux-hwe-5.11
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
focal
Released (5.11.0-34.36~20.04.1)
jammy Does not exist

linux-riscv-5.11
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
focal
Released (5.11.0-1018.19~20.04.2)
jammy Does not exist

linux
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-156.163)
upstream
Released (5.14~rc7)
trusty Not vulnerable
(3.11.0-12.19)
xenial Not vulnerable
(4.4.0-2.16)
impish Not vulnerable
(5.13.0-16.16)
focal
Released (5.4.0-84.94)
hirsute
Released (5.11.0-34.36)
jammy Not vulnerable
(5.13.0-19.19)
Patches:
Introduced by

89c8a4984fc98e625517bfe5083342d77ee35811

Fixed by c7dfa4009965a9b2d7b329ee970eb8da0d32f0bc|local-CVE-2021-3656-fix
linux-aws
Launchpad, Ubuntu, Debian
upstream
Released (5.14~rc7)
trusty Not vulnerable
(4.4.0-1002.2)
xenial Not vulnerable
(4.4.0-1001.10)
impish Not vulnerable
(5.13.0-1005.6)
focal
Released (5.4.0-1056.59)
hirsute
Released (5.11.0-1017.18)
bionic
Released (4.15.0-1111.118)
jammy Not vulnerable
(5.13.0-1005.6)
linux-kvm
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Not vulnerable
(4.4.0-1004.9)
impish Not vulnerable
(5.13.0-1002.2)
bionic
Released (4.15.0-1099.101)
upstream
Released (5.14~rc7)
focal
Released (5.4.0-1046.48)
hirsute
Released (5.11.0-1015.16)
jammy Not vulnerable
(5.13.0-1004.4)
linux-oracle
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial
Released (4.15.0-1080.88~16.04.1)
impish Not vulnerable
(5.13.0-1008.10)
bionic
Released (4.15.0-1080.88)
upstream
Released (5.14~rc7)
focal
Released (5.4.0-1054.58)
hirsute
Released (5.11.0-1017.18)
jammy Not vulnerable
(5.13.0-1008.10)
linux-oem-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

impish Does not exist

bionic Does not exist

hirsute Does not exist

upstream
Released (5.14~rc7)
focal
Released (5.13.0-1012.16)
jammy Does not exist

linux-aws-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

impish Does not exist

bionic Does not exist

hirsute Does not exist

upstream
Released (5.14~rc7)
focal
Released (5.11.0-1017.18~20.04.1)
jammy Does not exist

linux-azure-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

impish Does not exist

bionic Does not exist

hirsute Does not exist

upstream
Released (5.14~rc7)
focal
Released (5.11.0-1015.16~20.04.1)
jammy Does not exist

linux-oracle-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

impish Does not exist

bionic Does not exist

hirsute Does not exist

upstream
Released (5.14~rc7)
focal
Released (5.11.0-1017.18~20.04.1)
jammy Does not exist

linux-ibm
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

impish Does not exist

bionic Does not exist

focal
Released (5.4.0-1004.5)
hirsute Does not exist

upstream
Released (5.14~rc7)
jammy Not vulnerable
(5.15.0-1002.2)
linux-gcp-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal
Released (5.11.0-1018.20~20.04.2)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-oem-5.14
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable
(5.14.0-1004.4)
hirsute Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
jammy Does not exist

linux-intel-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable
(5.13.0-1007.7)
hirsute Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
jammy Does not exist

linux-azure-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1009.10~20.04.2)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-hwe-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-21.21~20.04.1)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-aws-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1008.9~20.04.2)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-fips
Launchpad, Ubuntu, Debian
trusty Does not exist

bionic Does not exist

focal Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.14~rc7)
xenial Not vulnerable
(4.4.0-1074.80)
jammy Does not exist

linux-oracle-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1011.13~20.04.2)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-gcp-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1008.9~20.04.3)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-ibm-5.4
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

focal Does not exist

impish Does not exist

bionic Not vulnerable
(5.4.0-1010.11~18.04.2)
upstream
Released (5.14~rc7)
jammy Does not exist

linux-azure-fde
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.4.0-1063.66+cvm2.2)
upstream
Released (5.14~rc7)
jammy Needs triage

linux-lowlatency
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable
(5.15.0-22.22)
upstream
Released (5.14~rc7)
linux-oem-5.17
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable
(5.17.0-1003.3)
upstream
Released (5.14~rc7)
linux-intel-iotg
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable

upstream Needs triage

linux-intel-iotg-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

impish Does not exist

jammy Does not exist

upstream Needs triage

linux-lowlatency-hwe-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

upstream Needs triage

linux-hwe-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

upstream Needs triage

linux-aws-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Does not exist

upstream Needs triage

focal Not vulnerable

linux-gcp-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

upstream Needs triage

linux-gke-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

upstream Needs triage

linux-azure-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

upstream Needs triage