CVE-2021-3630

Published: 30 June 2021

An out-of-bounds write vulnerability was found in DjVuLibre in DJVU::DjVuTXT::decode() in DjVuText.cpp via a crafted djvu file which may lead to crash and segmentation fault. This flaw affects DjVuLibre versions prior to 3.5.28.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
djvulibre
Launchpad, Ubuntu, Debian
Upstream
Released (3.5.27.1-12)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3.5.27.1-14ubuntu0.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (3.5.27.1-8ubuntu0.4)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (3.5.27.1-5ubuntu0.1+esm2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://sourceforge.net/p/djvu/djvulibre-git/ci/7b0ef20690e08f1fe124aebbf42f6310e2f40f81/