Your submission was sent successfully! Close

CVE-2021-35560

Published: 20 October 2021

Vulnerability in the Java SE product of Oracle Java SE (component: Deployment). The supported version that is affected is Java SE: 8u301. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in takeover of Java SE. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.1 Base Score 7.5 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H).

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
icedtea-web
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

Ubuntu 21.10 (Impish Indri) Not vulnerable

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

openjdk-12
Launchpad, Ubuntu, Debian
Upstream Not vulnerable
(Java 8 only)
Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

openjdk-13
Launchpad, Ubuntu, Debian
Upstream Not vulnerable
(Java 8 only)
Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(Java 8 only)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

openjdk-15
Launchpad, Ubuntu, Debian
Upstream Not vulnerable
(Java 8 only)
Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(Java 8 only)
Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

openjdk-8
Launchpad, Ubuntu, Debian
Upstream Not vulnerable
(Java deployments)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(Java deployments)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(Java deployments)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(Java deployments)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(Java deployments)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(Java deployments)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

openjdk-9
Launchpad, Ubuntu, Debian
Upstream Not vulnerable
(Java 8 only)
Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(Java 8 only)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

openjdk-lts
Launchpad, Ubuntu, Debian
Upstream Not vulnerable
(Java 8 only)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(Java 8 only)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(Java 8 only)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(Java 8 only)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(Java 8 only)
Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Notes

AuthorNote
sbeattie
java 8 only, Deployments not included in openjdk, only Oracle
Java.

References