Your submission was sent successfully! Close

CVE-2021-3504

Published: 11 May 2021

A flaw was found in the hivex library in versions before 1.3.20. It is caused due to a lack of bounds check within the hivex_open function. An attacker could input a specially crafted Windows Registry (hive) file which would cause hivex to read memory beyond its normal bounds or cause the program to crash. The highest threat from this vulnerability is to system availability.

Priority

Medium

CVSS 3 base score: 5.4

Status

Package Release Status
hivex
Launchpad, Ubuntu, Debian
Upstream Ignored
(out of standard support)
Ubuntu 21.10 (Impish Indri)
Released (1.3.19-1ubuntu3.21.10.1)
Ubuntu 21.04 (Hirsute Hippo)
Released (1.3.19-1ubuntu3.21.04.1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (1.3.18-2ubuntu0.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.3.15-1ubuntu0.1)
Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist