CVE-2021-3500

Published: 30 April 2021

A flaw was found in djvulibre-3.5.28 and earlier. A Stack overflow in function DJVU::DjVuDocument::get_djvu_file() via crafted djvu file may lead to application crash and other consequences.

Priority

Low

CVSS 3 base score: 7.8

Status

Package Release Status
djvulibre
Launchpad, Ubuntu, Debian
Upstream
Released (3.5.28-2)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(3.5.28-2)
Ubuntu 21.04 (Hirsute Hippo)
Released (3.5.28-1ubuntu0.1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (3.5.27.1-14ubuntu0.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (3.5.27.1-8ubuntu0.3)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (3.5.27.1-5ubuntu0.1+esm1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Vendor: https://src.fedoraproject.org/rpms/djvulibre/c/fc359410f7131e4ea0a892ef78e6da72f29afeee.patch