CVE-2021-3468

Published: 02 June 2021

A flaw was found in avahi in versions 0.6 up to 0.8. The event used to signal the termination of the client connection on the avahi Unix socket is not correctly handled in the client_work function, allowing a local attacker to trigger an infinite loop. The highest threat from this vulnerability is to the availability of the avahi service, which becomes unresponsive after this flaw is triggered.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
avahi
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 21.04 (Hirsute Hippo)
Released (0.8-5ubuntu3)
Ubuntu 20.04 LTS (Focal Fossa)
Released (0.7-4ubuntu7.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0.7-3.1ubuntu1.3)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (0.6.32~rc+dfsg-1ubuntu2.3+esm1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (0.6.31-4ubuntu1.3+esm1)
Patches:
Other: https://github.com/lathiat/avahi/pull/330