CVE-2021-31808

Published: 27 May 2021

An issue was discovered in Squid before 4.15 and 5.x before 5.0.6. Due to an input-validation bug, it is vulnerable to a Denial of Service attack (against all clients using the proxy). A client sends an HTTP Range request to trigger this.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
squid
Launchpad, Ubuntu, Debian
Upstream
Released (4.15,4.13-10)
Ubuntu 21.04 (Hirsute Hippo)
Released (4.13-1ubuntu4.1)
Ubuntu 20.10 (Groovy Gorilla)
Released (4.13-1ubuntu2.2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (4.10-1ubuntu1.4)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: http://www.squid-cache.org/Versions/v4/changesets/squid-4-e7cf864f938f24eea8af0692c04d16790983c823.patch
Upstream: https://github.com/squid-cache/squid/commit/e7cf864f938f24eea8af0692c04d16790983c823
squid3
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.10 (Groovy Gorilla) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver)
Released (3.5.27-1ubuntu1.11)
Ubuntu 16.04 ESM (Xenial Xerus) Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist