Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2021-30951

Published: 26 January 2022

A use after free issue was addressed with improved memory management. This issue is fixed in tvOS 15.2, macOS Monterey 12.1, Safari 15.2, iOS 15.2 and iPadOS 15.2, watchOS 8.3. Processing maliciously crafted web content may lead to arbitrary code execution.

Notes

AuthorNote
jdstrand
webkit receives limited support. For details, see
https://wiki.ubuntu.com/SecurityTeam/FAQ#webkit
webkit in Ubuntu uses the JavaScriptCore (JSC) engine, not V8

Priority

Medium

Cvss 3 Severity Score

8.8

Score breakdown

Status

Package Release Status
qtwebkit-opensource-src
Launchpad, Ubuntu, Debian
jammy Needs triage

bionic Needs triage

trusty Does not exist

xenial Needs triage

focal Needs triage

upstream Needs triage

kinetic Ignored
(end of life, was needs-triage)
impish Ignored
(end of life)
mantic Needs triage

lunar Ignored
(end of life, was needs-triage)
qtwebkit-source
Launchpad, Ubuntu, Debian
impish Does not exist

jammy Does not exist

lunar Does not exist

trusty Does not exist

bionic Needs triage

focal Does not exist

upstream Needs triage

xenial Needs triage

kinetic Does not exist

mantic Does not exist

webkit2gtk
Launchpad, Ubuntu, Debian
jammy
Released (2.35.2-1)
lunar
Released (2.35.2-1)
upstream
Released (2.34.4)
trusty Does not exist

xenial Deferred

bionic Deferred

focal
Released (2.34.4-0ubuntu0.20.04.1)
impish
Released (2.34.4-0ubuntu0.21.10.1)
kinetic
Released (2.35.2-1)
mantic
Released (2.35.2-1)
webkitgtk
Launchpad, Ubuntu, Debian
jammy Does not exist

lunar Does not exist

trusty Does not exist

bionic Needs triage

focal Does not exist

impish Does not exist

upstream Needs triage

xenial Needs triage

kinetic Does not exist

mantic Does not exist

wpewebkit
Launchpad, Ubuntu, Debian
jammy Needs triage

lunar Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Needs triage

upstream Needs triage

impish Ignored
(end of life)
kinetic Does not exist

mantic Does not exist

Severity score breakdown

Parameter Value
Base score 8.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H