Your submission was sent successfully! Close

You have successfully unsubscribed! Close

CVE-2021-28662

Published: 27 May 2021

An issue was discovered in Squid 4.x before 4.15 and 5.x before 5.0.6. If a remote server sends a certain response header over HTTP or HTTPS, there is a denial of service. This header can plausibly occur in benign network traffic.

Notes

AuthorNote
mdeslaur
per upstream, all Squid older than 4.0 are not vulnerable.
Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
squid
Launchpad, Ubuntu, Debian
bionic Does not exist

focal
Released (4.10-1ubuntu1.4)
groovy
Released (4.13-1ubuntu2.2)
hirsute
Released (4.13-1ubuntu4.1)
impish
Released (4.13-10ubuntu1)
jammy
Released (4.13-10ubuntu1)
trusty Does not exist

upstream
Released (4.15,4.13-10)
xenial Does not exist

Patches:
upstream: http://www.squid-cache.org/Versions/v4/changesets/squid-4-b1c37c9e7b30d0efb5e5ccf8200f2a646b9c36f8.patch
upstream: http://www.squid-cache.org/Versions/v6/changesets/squid-6-051824924c709bd6162a378f746fb859454c674e.patch
upstream: https://github.com/squid-cache/squid/commit/051824924c709bd6162a378f746fb859454c674e (master)
upstream: https://github.com/squid-cache/squid/commit/b1c37c9e7b30d0efb5e5ccf8200f2a646b9c36f8 (v4)
squid3
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Not vulnerable