CVE-2021-27135

Published: 10 February 2021

xterm before Patch #366 allows remote attackers to execute arbitrary code or cause a denial of service (segmentation fault) via a crafted UTF-8 combining character sequence.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
xterm
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla)
Released (353-1ubuntu1.20.10.2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (353-1ubuntu1.20.04.2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (330-1ubuntu2.2)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (322-1ubuntu1.2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/ThomasDickey/xterm-snapshots/commit/82ba55b8f994ab30ff561a347b82ea340ba7075c
Upstream: https://github.com/ThomasDickey/xterm-snapshots/commit/f80e543c6dee5ecfe54c58d351fe418ce5f1959b