CVE-2021-26691

Published: 10 June 2021

In Apache HTTP Server versions 2.4.0 to 2.4.46 a specially crafted SessionHeader sent by an origin server could cause a heap overflow

Priority

Medium

Status

Package Release Status
apache2
Launchpad, Ubuntu, Debian
Upstream
Released (2.4.46-6)
Ubuntu 21.04 (Hirsute Hippo)
Released (2.4.46-4ubuntu1.1)
Ubuntu 20.10 (Groovy Gorilla)
Released (2.4.46-1ubuntu1.2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.4.41-4ubuntu3.3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.4.29-1ubuntu4.16)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.4.18-2ubuntu3.17+esm1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.4.7-1ubuntu4.22+esm1)
Patches:
Upstream: https://github.com/apache/httpd/commit/7e09dd714fc62c08c5b0319ed7b9702594faf49b