CVE-2021-23991

Published: 13 April 2021

If a Thunderbird user has previously imported Alice's OpenPGP key, and Alice has extended the validity period of her key, but Alice's updated key has not yet been imported, an attacker may send an email containing a crafted version of Alice's key with an invalid subkey, Thunderbird might subsequently attempt to use the invalid subkey, and will fail to send encrypted email to Alice. This vulnerability affects Thunderbird < 78.9.1.

Priority

Medium

CVSS 3 base score: 6.8

Status

Package Release Status
thunderbird
Launchpad, Ubuntu, Debian
Upstream
Released (78.9.1)
Ubuntu 21.04 (Hirsute Hippo)
Released (1:78.11.0+build1-0ubuntu0.21.04.2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (1:78.11.0+build1-0ubuntu0.20.04.2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1:78.11.0+build1-0ubuntu0.18.04.2)
Ubuntu 16.04 ESM (Xenial Xerus) Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist