Your submission was sent successfully! Close

CVE-2021-23437

Published: 3 September 2021

The package pillow 5.2.0 and before 8.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the getrgb function.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
pillow
Launchpad, Ubuntu, Debian
bionic
Released (5.1.0-1ubuntu0.7)
focal
Released (7.0.0-4ubuntu0.5)
hirsute
Released (8.1.2-1ubuntu0.2)
impish
Released (8.1.2+dfsg-0.3ubuntu0.1)
jammy
Released (9.0.0-1)
trusty
Released (2.3.0-1ubuntu3.4+esm3)
upstream
Released (8.3.2)
xenial
Released (3.1.2-0ubuntu1.6+esm1)
Patches:
upstream: https://github.com/python-pillow/Pillow/commit/9e08eb8f78fdfd2f476e1b20b7cf38683754866b
pillow-python2
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Needs triage

hirsute Does not exist

impish Does not exist

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

python-imaging
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist