Your submission was sent successfully! Close

You have successfully unsubscribed! Close

CVE-2021-21408

Published: 10 January 2022

Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.43 and 4.0.3, template authors could run restricted static php methods. Users should upgrade to version 3.1.43 or 4.0.3 to receive a patch.

Priority

Medium

Cvss 3 Severity Score

8.8

Score breakdown

Status

Package Release Status
smarty3
Launchpad, Ubuntu, Debian
bionic
Released (3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1)
focal
Released (3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1~esm1)
hirsute Ignored
(reached end-of-life)
impish
Released (3.1.39-2ubuntu0.21.10.1)
jammy
Released (3.1.39-2ubuntu1)
kinetic
Released (3.1.39-2ubuntu1)
trusty Does not exist

upstream
Released (4.0.3,3.1.43)
xenial
Released (3.1.21-1ubuntu1+esm1)
Patches:
upstream: https://github.com/smarty-php/smarty/commit/28519ca00fe6890ef2d464f8400a16188c4b6f36

Severity score breakdown

Parameter Value
Base score 8.8
Attack vector Network
Attack complexity Low
Privileges required Low
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H