Your submission was sent successfully! Close

CVE-2021-20234

Published: 01 April 2021

An uncontrolled resource consumption (memory leak) flaw was found in the ZeroMQ client in versions before 4.3.3 in src/pipe.cpp. This issue causes a client that connects to multiple malicious or compromised servers to crash. The highest threat from this vulnerability is to system availability.

Priority

Low

CVSS 3 base score: 6.5

Status

Package Release Status
zeromq3
Launchpad, Ubuntu, Debian
Upstream
Released (4.3.3-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(4.3.4-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.3.4-1)
Ubuntu 20.04 LTS (Focal Fossa) Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Needs triage