Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2020-8945

Published: 12 February 2020

The proglottis Go wrapper before 0.1.1 for the GPGME library has a use-after-free, as demonstrated by use for container image pulls by Docker or CRI-O. This leads to a crash or potential code execution during GPG signature verification.

Priority

Medium

Cvss 3 Severity Score

7.5

Score breakdown

Status

Package Release Status
golang-github-proglottis-gpgme
Launchpad, Ubuntu, Debian
bionic Does not exist

eoan Ignored
(end of life)
focal Needs triage

groovy Not vulnerable
(0.1.1-1)
hirsute Not vulnerable
(0.1.1-1)
impish Not vulnerable
(0.1.1-1)
jammy Not vulnerable
(0.1.1-1)
kinetic Not vulnerable
(0.1.1-1)
lunar Not vulnerable
(0.1.1-1)
mantic Not vulnerable
(0.1.1-1)
trusty Does not exist

upstream Needs triage

xenial Does not exist

singularity-container
Launchpad, Ubuntu, Debian
bionic Needs triage

eoan Ignored
(end of life)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

mantic Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

Severity score breakdown

Parameter Value
Base score 7.5
Attack vector Network
Attack complexity High
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H