CVE-2020-8130

Published: 24 February 2020

There is an OS command injection vulnerability in Ruby Rake < 12.3.3 in Rake::FileList when supplying a filename that begins with the pipe character `|`.

Priority

Medium

CVSS 3 base score: 6.4

Status

Package Release Status
rake
Launchpad, Ubuntu, Debian
Upstream
Released (12.3.3-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (12.3.1-1ubuntu0.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (10.5.0-2ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/ruby/rake/commit/5b8f8fc41a5d7d7d6a5d767e48464c60884d3aee