CVE-2020-8086

Published: 28 January 2020

The mod_auth_ldap and mod_auth_ldap2 Community Modules through 2020-01-27 for Prosody incompletely verify the XMPP address passed to the is_admin() function. This grants remote entities admin-only functionality if their username matches the username of a local admin.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
prosody-modules
Launchpad, Ubuntu, Debian
Upstream
Released (0.0~hg20200128.09e7e880e056+dfsg-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(0.0~hg20200128.09e7e880e056+dfsg-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.0~hg20200128.09e7e880e056+dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist