CVE-2020-5212

Published: 28 January 2020

In NetHack before 3.6.5, an extremely long value for the MENUCOLOR configuration file option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to upload their own configuration files. Users should upgrade to NetHack 3.6.5.

Priority

Low

CVSS 3 base score: 9.8

Status

Package Release Status
nethack
Launchpad, Ubuntu, Debian
Upstream
Released (3.6.5)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(3.6.6-1)
Ubuntu 20.04 LTS (Focal Fossa) Needed

Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist