Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2020-36773

Published: 4 February 2024

Artifex Ghostscript before 9.53.0 has an out-of-bounds write and use-after-free in devices/vector/gdevtxtw.c (for txtwrite) because a single character code in a PDF document can map to more than one Unicode code point (e.g., for a ligature).

Notes

AuthorNote
mdeslaur
This issue was introduced in 9.51 as described in the patch.
The reproducer doesn't work on focal.

Priority

Medium

Cvss 3 Severity Score

9.8

Score breakdown

Status

Package Release Status
ghostscript
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Not vulnerable
(9.50~dfsg-5ubuntu4.11)
jammy Not vulnerable
(9.55.0~dfsg1-0ubuntu5.5)
mantic Not vulnerable

trusty Ignored
(end of standard support)
upstream
Released (9.53.0~dfsg-1)
xenial Not vulnerable

Patches:
upstream: https://git.ghostscript.com/?p=ghostpdl.git;h=8c7bd787defa071c96289b7da9397f673fddb874

Severity score breakdown

Parameter Value
Base score 9.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H