CVE-2020-36228

Published: 26 January 2021

An integer underflow was discovered in OpenLDAP before 2.4.57 leading to a slapd crash in the Certificate List Exact Assertion processing, resulting in denial of service.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
openldap
Launchpad, Ubuntu, Debian
Upstream
Released (2.4.57+dfsg-1)
Ubuntu 21.04 (Hirsute Hippo)
Released (2.4.57+dfsg-2ubuntu1)
Ubuntu 20.10 (Groovy Gorilla)
Released (2.4.53+dfsg-1ubuntu1.3)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.4.49+dfsg-2ubuntu1.6)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.4.45+dfsg-1ubuntu1.9)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2.4.42+dfsg-2ubuntu3.12)
Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://git.openldap.org/openldap/openldap/-/commit/91dccd25c347733b365adc74cb07d074512ed5ad