Your submission was sent successfully! Close

CVE-2020-28362

Published: 18 November 2020

Go before 1.14.12 and 1.15.x before 1.15.4 allows Denial of Service.

Notes

AuthorNote
mdeslaur
Packages built using golang need to be rebuilt once the
vulnerability has been fixed. This CVE entry does not
list packages that need rebuilding outside of the main
repository or the Ubuntu variants with PPA overlays.

vulnerable code introduced in 1.14
Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
golang
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

golang-1.10
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(code not present)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Not vulnerable
(code not present)
upstream Needs triage

xenial Not vulnerable
(code not present)
golang-1.13
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(code not present)
focal Not vulnerable
(code not present)
groovy Not vulnerable
(code not present)
hirsute Not vulnerable
(code not present)
impish Not vulnerable
(code not present)
jammy Not vulnerable
(code not present)
precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Not vulnerable
(code not present)
golang-1.14
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Needed

groovy Ignored
(reached end-of-life)
hirsute Ignored
(reached end-of-life)
impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (1.14.12)
xenial Does not exist

golang-1.15
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

groovy Ignored
(reached end-of-life)
hirsute Ignored
(reached end-of-life)
impish Ignored
(reached end-of-life)
precise Does not exist

trusty Does not exist

upstream
Released (1.15.5)
xenial Does not exist

golang-1.6
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Not vulnerable
(code not present)
golang-1.8
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(code not present)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

golang-1.9
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(code not present)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist