CVE-2020-28020

Published: 04 May 2021

Exim 4 before 4.92 allows Integer Overflow to Buffer Overflow, in which an unauthenticated remote attacker can execute arbitrary code by leveraging the mishandling of continuation lines during header-length restriction.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
exim4
Launchpad, Ubuntu, Debian
Upstream
Released (4.92)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.94-15ubuntu1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(4.94-7ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.93-13ubuntu1.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.90.1-1ubuntu1.8)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (4.86.2-2ubuntu2.6+esm1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (4.82-3ubuntu2.4+esm3)
Patches:
Upstream: https://github.com/Exim/exim/commit/56ac062a3ff94fc4e1bbfc2293119c079a4e980b