Your submission was sent successfully! Close

CVE-2020-28019

Published: 04 May 2021

Exim 4 before 4.94.2 has Improper Initialization that can lead to recursion-based stack consumption or other consequences. This occurs because use of certain getc functions is mishandled when a client uses BDAT instead of DATA.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
exim4
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri)
Released (4.94-15ubuntu1.2)
Ubuntu 21.04 (Hirsute Hippo)
Released (4.94-15ubuntu1.2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (4.93-13ubuntu1.5)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.90.1-1ubuntu1.8)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable

Notes

AuthorNote
leosilva
trusty/xenial ESM not affected.
vulnerability was introduced by: https://git.exim.org/exim.git/patch/7e3ce68e68ab9b8906a637d352993abf361554e2

References