Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2020-27751

Published: 8 December 2020

A flaw was found in ImageMagick in MagickCore/quantum-export.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of values outside the range of type `unsigned long long` as well as a shift exponent that is too large for 64-bit type. This would most likely lead to an impact to application availability, but could potentially cause other problems related to undefined behavior. This flaw affects ImageMagick versions prior to 7.0.9-0.

Priority

Low

Cvss 3 Severity Score

3.3

Score breakdown

Status

Package Release Status
imagemagick
Launchpad, Ubuntu, Debian
hirsute Not vulnerable
(8:6.9.11.60+dfsg-1ubuntu1)
bionic
Released (8:6.9.7.4+dfsg-16ubuntu6.11)
focal
Released (8:6.9.10.23+dfsg-2.1ubuntu11.4)
groovy
Released (8:6.9.10.23+dfsg-2.1ubuntu13.3)
trusty Needed

xenial Needed

kinetic Not vulnerable
(8:6.9.11.60+dfsg-1ubuntu1)
lunar Not vulnerable
(8:6.9.11.60+dfsg-1ubuntu1)
impish Not vulnerable
(8:6.9.11.60+dfsg-1ubuntu1)
jammy Not vulnerable
(8:6.9.11.60+dfsg-1ubuntu1)
upstream
Released (8:6.9.11.24+dfsg-1)
mantic Not vulnerable
(8:6.9.11.60+dfsg-1ubuntu1)
Patches:
upstream: https://github.com/ImageMagick/ImageMagick6/commit/879bb6a13ece5508cd983bc3d64ced23900b60ee

Severity score breakdown

Parameter Value
Base score 3.3
Attack vector Local
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact Low
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L