CVE-2020-27351

Published: 09 December 2020

Various memory and file descriptor leaks were found in apt-python files python/arfile.cc, python/tag.cc, python/tarfile.cc, aka GHSL-2020-170. This issue affects: python-apt 1.1.0~beta1 versions prior to 1.1.0~beta1ubuntu0.16.04.10; 1.6.5ubuntu0 versions prior to 1.6.5ubuntu0.4; 2.0.0ubuntu0 versions prior to 2.0.0ubuntu0.20.04.2; 2.1.3ubuntu1 versions prior to 2.1.3ubuntu1.1;

Priority

Medium

CVSS 3 base score: 2.8

Status

Package Release Status
python-apt
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo)
Released (2.1.7)
Ubuntu 20.10 (Groovy Gorilla)
Released (2.1.3ubuntu1.1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.0.0ubuntu0.20.04.2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.6.5ubuntu0.4)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (1.1.0~beta1ubuntu0.16.04.10)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (0.9.3.5ubuntu3+esm4)