Your submission was sent successfully! Close

CVE-2020-26558

Published: 8 June 2021

Bluetooth LE and BR/EDR secure pairing in Bluetooth Core Specification 2.1 through 5.2 may permit a nearby man-in-the-middle attacker to identify the Passkey used during pairing (in the Passkey authentication procedure) by reflection of the public key and the authentication evidence of the initiating device, potentially permitting this attacker to complete authenticated pairing with the responding device using the correct Passkey for the pairing session. The attack methodology determines the Passkey value one bit at a time.

From the Ubuntu security team

It was discovered that the bluetooth subsystem in the Linux kernel did not properly perform access control. An authenticated attacker could possibly use this to expose sensitive information.

Priority

Medium

CVSS 3 base score: 4.6

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-151.157)
focal
Released (5.4.0-80.90)
upstream
Released (5.13~rc1)
hirsute
Released (5.11.0-31.33)
xenial
Released (4.4.0-219.252)
groovy Ignored
(was pending now end-of-life)
impish Not vulnerable
(5.13.0-14.14)
trusty Ignored
(was needed ESM criteria)
jammy Not vulnerable
(5.13.0-19.19)
linux-hwe
Launchpad, Ubuntu, Debian
bionic Ignored
(replaced by linux-hwe-5.4)
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial
Released (4.15.0-151.157~16.04.1)
groovy Does not exist

impish Does not exist

jammy Does not exist

linux-hwe-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
bionic
Released (5.4.0-80.90~18.04.1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-hwe-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
focal Ignored
(was pending [5.8.0-67.75] now end-of-life)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-hwe-edge
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-hwe-5.4)
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Ignored
(superseded by linux-hwe)
groovy Does not exist

impish Does not exist

jammy Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
xenial Does not exist

groovy Does not exist

impish Does not exist

trusty
Released (4.4.0-219.252~14.04.1)
jammy Does not exist

linux-aws-5.0
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-aws-5.3)
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-aws-5.3
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-aws-5.4)
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-aws-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
bionic
Released (5.4.0-1054.57~18.04.1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-aws-hwe
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial
Released (4.15.0-1109.116~16.04.1)
groovy Does not exist

impish Does not exist

jammy Does not exist

linux-azure
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-azure-5.3)
hirsute
Released (5.11.0-1013.14)
upstream
Released (5.13~rc1)
focal
Released (5.4.0-1055.57)
trusty
Released (4.15.0-1121.134~14.04.1)
xenial
Released (4.15.0-1121.134~16.04.1)
groovy Ignored
(reached end-of-life)
impish Not vulnerable
(5.11.0-1013.14+21.10.1)
jammy Not vulnerable
(5.13.0-1006.7)
linux-azure-4.15
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1121.134)
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-azure-5.3
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-azure-5.4)
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-azure-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
bionic
Released (5.4.0-1055.57~18.04.1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-dell300x
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
bionic
Released (4.15.0-1027.32)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-azure-edge
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-azure-5.3)
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-gcp
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-gcp-5.3)
focal
Released (5.4.0-1049.53)
hirsute
Released (5.11.0-1017.19)
upstream
Released (5.13~rc1)
trusty Does not exist

xenial
Released (4.15.0-1106.120~16.04.1)
groovy Ignored
(reached end-of-life)
impish Not vulnerable
(5.11.0-1016.18+21.10.2)
jammy Not vulnerable
(5.13.0-1005.6)
linux-gcp-4.15
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1106.120)
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-gcp-5.3
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-gcp-5.4)
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-gcp-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
bionic
Released (5.4.0-1049.53~18.04.1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-gcp-edge
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-gcp-5.3)
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-gke
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
focal
Released (5.4.0-1049.52)
trusty Does not exist

xenial Ignored
(reached end of standard support)
groovy Does not exist

impish Does not exist

jammy Not vulnerable
(5.15.0-1002.2)
linux-gke-4.15
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-gke-5.0
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-gke-5.3
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

bionic Ignored
(was needed now end-of-life)
upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-gke-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

bionic
Released (5.4.0-1049.52~18.04.1)
upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-gkeop
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
focal
Released (5.4.0-1021.22)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-gkeop-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

bionic
Released (5.4.0-1021.22~18.04.1)
upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-oracle
Launchpad, Ubuntu, Debian
upstream
Released (5.13~rc1)
bionic
Released (4.15.0-1078.86)
focal
Released (5.4.0-1052.56)
hirsute
Released (5.11.0-1016.17)
trusty Does not exist

xenial
Released (4.15.0-1078.86~16.04.1)
groovy Ignored
(reached end-of-life)
impish Not vulnerable
(5.11.0-1015.16+21.10.1)
jammy Not vulnerable
(5.13.0-1008.10)
linux-oracle-5.0
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-oracle-5.3)
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-oracle-5.3
Launchpad, Ubuntu, Debian
bionic Ignored
(superseded by linux-oracle-5.4)
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-oracle-5.4
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

bionic
Released (5.4.0-1052.56~18.04.1)
upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-oem
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Ignored
(superseded by linux-hwe)
groovy Does not exist

impish Does not exist

jammy Does not exist

linux-oem-5.6
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Ignored
(was needs-triage now end-of-life)
hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-oem-5.10
Launchpad, Ubuntu, Debian
bionic Does not exist

focal
Released (5.10.0-1032.33)
hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-oem-osp1
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-raspi
Launchpad, Ubuntu, Debian
bionic Does not exist

focal
Released (5.4.0-1041.45)
hirsute
Released (5.11.0-1016.17)
upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Ignored
(reached end-of-life)
impish Not vulnerable
(5.13.0-1006.7)
jammy Not vulnerable
(5.13.0-1008.9)
linux-raspi2
Launchpad, Ubuntu, Debian
focal Ignored
(replaced by linux-raspi)
hirsute Does not exist

bionic
Released (4.15.0-1092.98)
upstream
Released (5.13~rc1)
trusty Does not exist

xenial Ignored
(was needs-triage now end-of-life)
groovy Does not exist

impish Does not exist

jammy Does not exist

linux-raspi2-5.3
Launchpad, Ubuntu, Debian
focal Does not exist

hirsute Does not exist

bionic Ignored
(was needed now end-of-life)
upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-raspi-5.4
Launchpad, Ubuntu, Debian
bionic
Released (5.4.0-1041.45~18.04.1)
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-riscv
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (5.13~rc1)
focal Ignored
(was needs-triage now end-of-life)
hirsute
Released (5.11.0-1017.18)
trusty Does not exist

xenial Does not exist

groovy Ignored
(reached end-of-life)
impish Not vulnerable
(5.13.0-1002.2)
jammy Not vulnerable
(5.13.0-1004.4)
linux-snapdragon
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1109.118)
focal Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Ignored
(was needs-triage now end-of-life)
groovy Does not exist

impish Does not exist

jammy Does not exist

linux-aws-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

focal
Released (5.8.0-1042.44~20.04.1)
upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-azure-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
focal
Released (5.8.0-1040.43~20.04.1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-gcp-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

focal
Released (5.8.0-1039.41)
upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-oracle-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

upstream
Released (5.13~rc1)
focal
Released (5.8.0-1038.39~20.04.1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-riscv-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

focal Ignored
(was pending [5.8.0-33.36] now end-of-life)
upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

groovy Does not exist

impish Does not exist

jammy Does not exist

linux-aws
Launchpad, Ubuntu, Debian
hirsute
Released (5.11.0-1016.17)
upstream
Released (5.13~rc1)
focal
Released (5.4.0-1054.57)
bionic
Released (4.15.0-1109.116)
xenial
Released (4.4.0-1135.149)
groovy Ignored
(reached end-of-life)
impish Not vulnerable
(5.11.0-1015.16+21.10.1)
trusty
Released (4.4.0-1099.104)
jammy Not vulnerable
(5.13.0-1005.6)
linux-kvm
Launchpad, Ubuntu, Debian
upstream
Released (5.13~rc1)
focal
Released (5.4.0-1044.46)
bionic
Released (4.15.0-1097.99)
hirsute
Released (5.11.0-1014.15)
trusty Does not exist

groovy Ignored
(reached end-of-life)
impish Not vulnerable
(5.13.0-1001.1)
xenial
Released (4.4.0-1100.109)
jammy Not vulnerable
(5.13.0-1004.4)
linux-hwe-5.11
Launchpad, Ubuntu, Debian
focal
Released (5.11.0-34.36~20.04.1)
upstream
Released (5.13~rc1)
bionic Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

jammy Does not exist

linux-riscv-5.11
Launchpad, Ubuntu, Debian
focal
Released (5.11.0-1017.18~20.04.1)
upstream
Released (5.13~rc1)
bionic Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

jammy Does not exist

linux-oem-5.13
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable
(5.13.0-1009.10)
hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

impish Does not exist

jammy Does not exist

linux-aws-5.11
Launchpad, Ubuntu, Debian
bionic Does not exist

focal
Released (5.11.0-1016.17~20.04.1)
hirsute Does not exist

upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

impish Does not exist

jammy Does not exist

linux-azure-5.11
Launchpad, Ubuntu, Debian
bionic Does not exist

focal
Released (5.11.0-1013.14~20.04.1)
hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.13~rc1)
jammy Does not exist

linux-oracle-5.11
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

trusty Does not exist

xenial Does not exist

impish Does not exist

upstream
Released (5.13~rc1)
focal
Released (5.11.0-1016.17~20.04.1)
jammy Does not exist

linux-bluefield
Launchpad, Ubuntu, Debian
bionic Does not exist

hirsute Does not exist

focal
Released (5.4.0-1016.19)
upstream
Released (5.13~rc1)
trusty Does not exist

xenial Does not exist

impish Does not exist

jammy Does not exist

bluez
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial
Released (5.37-0ubuntu5.3+esm1)
groovy
Released (5.55-0ubuntu1.2)
impish Not vulnerable
(5.58-0ubuntu1)
jammy Not vulnerable
(5.58-0ubuntu1)
bionic
Released (5.48-0ubuntu3.5)
focal
Released (5.53-0ubuntu3.2)
hirsute
Released (5.56-0ubuntu4.1)
upstream Needs triage

linux-ibm
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

impish Does not exist

bionic Does not exist

hirsute Does not exist

focal Not vulnerable
(5.4.0-1003.4)
upstream
Released (5.13~rc1)
jammy Not vulnerable
(5.15.0-1002.2)
linux-gcp-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.13~rc1)
focal
Released (5.11.0-1017.19~20.04.1)
jammy Does not exist

linux-oem-5.14
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.14.0-1004.4)
upstream
Released (5.13~rc1)
jammy Does not exist

linux-intel-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

hirsute Does not exist

impish Does not exist

upstream
Released (5.13~rc1)
jammy Does not exist

linux-azure-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1009.10~20.04.2)
upstream
Released (5.13~rc1)
jammy Does not exist

linux-hwe-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable
(5.13.0-21.21~20.04.1)
impish Does not exist

upstream
Released (5.13~rc1)
jammy Does not exist

linux-aws-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable
(5.13.0-1008.9~20.04.2)
impish Does not exist

upstream
Released (5.13~rc1)
jammy Does not exist

linux-fips
Launchpad, Ubuntu, Debian
trusty Does not exist

bionic Does not exist

focal Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.13~rc1)
xenial Not vulnerable
(4.4.0-1073.79)
jammy Does not exist

linux-oracle-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1011.13~20.04.2)
upstream
Released (5.13~rc1)
jammy Does not exist

linux-gcp-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1008.9~20.04.3)
upstream
Released (5.13~rc1)
jammy Does not exist

linux-ibm-5.4
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

focal Does not exist

impish Does not exist

bionic Not vulnerable
(5.4.0-1010.11~18.04.2)
upstream
Released (5.13~rc1)
jammy Does not exist

linux-azure-fde
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Needed

upstream
Released (5.13~rc1)
jammy Does not exist

linux-lowlatency
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable

upstream Needs triage

linux-oem-5.17
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable

upstream Needs triage