Your submission was sent successfully! Close

CVE-2020-25669

Published: 5 November 2020

A vulnerability was found in the Linux Kernel where the function sunkbd_reinit having been scheduled by sunkbd_interrupt before sunkbd being freed. Though the dangling pointer is set to NULL in sunkbd_disconnect, there is still an alias in sunkbd_reinit causing Use After Free.

From the Ubuntu security team

Bodong Zhao discovered a use-after-free in the Sun keyboard driver implementation in the Linux kernel. A local attacker could use this to cause a denial of service or possibly execute arbitrary code.

Priority

Low

CVSS 3 base score: 7.8

Status

Package Release Status
linux-aws-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal Not vulnerable
(5.8.0-1035.37~20.04.1)
upstream
Released (5.10~rc5)
impish Does not exist

jammy Does not exist

linux-azure-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal Not vulnerable
(5.8.0-1033.35~20.04.1)
upstream
Released (5.10~rc5)
impish Does not exist

jammy Does not exist

linux-gcp-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal Not vulnerable
(5.8.0-1032.34~20.04.1)
upstream
Released (5.10~rc5)
impish Does not exist

jammy Does not exist

linux-oracle-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal Not vulnerable
(5.8.0-1031.32~20.04.2)
upstream
Released (5.10~rc5)
impish Does not exist

jammy Does not exist

linux-riscv-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal
Released (5.8.0-17.19~20.04.1)
groovy Does not exist

hirsute Does not exist

upstream
Released (5.10~rc5)
impish Does not exist

jammy Does not exist

linux-hwe-5.11
Launchpad, Ubuntu, Debian
focal Not vulnerable
(5.11.0-22.23~20.04.1)
upstream
Released (5.10~rc5)
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

linux-riscv-5.11
Launchpad, Ubuntu, Debian
focal Not vulnerable
(5.11.0-1015.16~20.04.1)
upstream
Released (5.10~rc5)
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

linux-oem-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable
(5.13.0-1009.10)
hirsute Does not exist

upstream
Released (5.10~rc5)
impish Does not exist

jammy Does not exist

linux-aws-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.11.0-1009.9~20.04.2)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-azure-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.11.0-1007.7~20.04.2)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-oracle-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.11.0-1008.8~20.04.1)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-bluefield
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

upstream
Released (5.10~rc5)
focal
Released (5.4.0-1011.14)
impish Does not exist

jammy Does not exist

linux
Launchpad, Ubuntu, Debian
upstream
Released (5.10~rc5)
bionic
Released (4.15.0-136.140)
precise Ignored
(was needs-triage ESM criteria)
impish Not vulnerable
(5.11.0-16.17)
focal
Released (5.4.0-66.74)
groovy
Released (5.8.0-44.50)
trusty Ignored
(was needed ESM criteria)
hirsute Not vulnerable
(5.10.0-14.15)
xenial
Released (4.4.0-201.233)
jammy Not vulnerable
(5.13.0-19.19)
linux-hwe
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

bionic Ignored
(replaced by linux-hwe-5.4)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc5)
xenial
Released (4.15.0-136.140~16.04.1)
jammy Does not exist

linux-hwe-5.4
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

bionic
Released (5.4.0-66.74~18.04.2)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-hwe-edge
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
xenial Ignored
(was needs-triage now end-of-life)
impish Does not exist

upstream
Released (5.10~rc5)
jammy Does not exist

linux-lts-trusty
Launchpad, Ubuntu, Debian
upstream
Released (5.10~rc5)
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

precise Ignored
(was needs-triage ESM criteria)
impish Does not exist

jammy Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
precise Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc5)
trusty
Released (4.4.0-201.233~14.04.1)
jammy Does not exist

linux-kvm
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

impish Not vulnerable
(5.11.0-1006.6)
bionic
Released (4.15.0-1085.87)
hirsute Not vulnerable
(5.8.0-1020.22+21.04.1)
upstream
Released (5.10~rc5)
focal
Released (5.4.0-1033.34)
xenial
Released (4.4.0-1087.96)
groovy
Released (5.8.0-1019.21)
jammy Not vulnerable
(5.13.0-1004.4)
linux-aws
Launchpad, Ubuntu, Debian
precise Does not exist

bionic
Released (4.15.0-1094.101)
trusty
Released (4.4.0-1085.89)
impish Not vulnerable
(5.11.0-1006.6)
focal
Released (5.4.0-1038.40)
groovy
Released (5.8.0-1024.26)
hirsute Not vulnerable
(5.8.0-1025.27+21.04.1)
upstream
Released (5.10~rc5)
xenial
Released (4.4.0-1121.135)
jammy Not vulnerable
(5.13.0-1005.6)
linux-aws-5.0
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
impish Does not exist

upstream
Released (5.10~rc5)
jammy Does not exist

linux-aws-5.3
Launchpad, Ubuntu, Debian
upstream
Released (5.10~rc5)
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
impish Does not exist

jammy Does not exist

linux-aws-5.4
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc5)
bionic
Released (5.4.0-1038.40~18.04.1)
jammy Does not exist

linux-aws-hwe
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

bionic Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc5)
xenial
Released (4.15.0-1094.101~16.04.1)
jammy Does not exist

linux-azure
Launchpad, Ubuntu, Debian
precise Does not exist

focal
Released (5.4.0-1040.42)
groovy
Released (5.8.0-1023.25)
bionic Ignored
(was needs-triage now end-of-life)
trusty
Released (4.15.0-1108.120~14.04.1)
impish Not vulnerable
(5.11.0-1004.4)
hirsute Not vulnerable
(5.8.0-1024.26+21.04.1)
upstream
Released (5.10~rc5)
xenial
Released (4.15.0-1108.120~16.04.1)
jammy Not vulnerable
(5.13.0-1006.7)
linux-azure-4.15
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc5)
bionic
Released (4.15.0-1108.120)
jammy Does not exist

linux-azure-5.3
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
impish Does not exist

upstream
Released (5.10~rc5)
jammy Does not exist

linux-azure-5.4
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

bionic
Released (5.4.0-1040.42~18.04.1)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-azure-edge
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
impish Does not exist

upstream
Released (5.10~rc5)
jammy Does not exist

linux-gcp
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

focal
Released (5.4.0-1037.40)
groovy
Released (5.8.0-1023.24)
hirsute Not vulnerable
(5.8.0-1024.25+21.04.1)
bionic Ignored
(was needs-triage now end-of-life)
impish Not vulnerable
(5.11.0-1006.6)
upstream
Released (5.10~rc5)
xenial
Released (4.15.0-1093.106~16.04.1)
jammy Not vulnerable
(5.13.0-1005.6)
linux-gcp-4.15
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc5)
bionic
Released (4.15.0-1093.106)
jammy Does not exist

linux-gcp-5.3
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
impish Does not exist

upstream
Released (5.10~rc5)
jammy Does not exist

linux-gcp-5.4
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-1037.40~18.04.1)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc5)
jammy Does not exist

linux-gcp-edge
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
impish Does not exist

upstream
Released (5.10~rc5)
jammy Does not exist

linux-gke-4.15
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc5)
bionic
Released (4.15.0-1079.84)
jammy Does not exist

linux-gke-5.0
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc5)
bionic Ignored
(was needed now end-of-life)
jammy Does not exist

linux-gke-5.3
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

bionic Ignored
(was needed now end-of-life)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-oracle
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

impish Not vulnerable
(5.11.0-1005.5)
focal
Released (5.4.0-1038.41)
upstream
Released (5.10~rc5)
groovy
Released (5.8.0-1021.22)
bionic
Released (4.15.0-1065.73)
xenial
Released (4.15.0-1065.73~16.04.1)
hirsute Not vulnerable
(5.8.0-1022.23+21.04.1)
jammy Not vulnerable
(5.13.0-1008.10)
linux-oracle-5.0
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
impish Does not exist

upstream
Released (5.10~rc5)
jammy Does not exist

linux-oracle-5.3
Launchpad, Ubuntu, Debian
upstream
Released (5.10~rc5)
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
impish Does not exist

jammy Does not exist

linux-oracle-5.4
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

bionic
Released (5.4.0-1038.41~18.04.1)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-oem
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

bionic Ignored
(was needed now end-of-life)
focal Does not exist

groovy Does not exist

hirsute Does not exist

xenial Ignored
(was needs-triage now end-of-life)
impish Does not exist

upstream
Released (5.10~rc5)
jammy Does not exist

linux-oem-5.6
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

focal
Released (5.6.0-1053.57)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-oem-osp1
Launchpad, Ubuntu, Debian
upstream
Released (5.10~rc5)
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

bionic Ignored
(was needs-triage now end-of-life)
jammy Does not exist

linux-raspi
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Not vulnerable
(5.11.0-1007.7)
hirsute Not vulnerable
(5.11.0-1003.3)
upstream
Released (5.10~rc5)
focal
Released (5.4.0-1029.32)
groovy
Released (5.8.0-1016.19)
jammy Not vulnerable
(5.13.0-1008.9)
linux-raspi2
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

focal Ignored
(replaced by linux-raspi)
groovy Does not exist

hirsute Does not exist

impish Does not exist

bionic
Released (4.15.0-1079.84)
upstream
Released (5.10~rc5)
xenial
Released (4.4.0-1145.155)
jammy Does not exist

linux-raspi2-5.3
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

bionic Ignored
(was needed now end-of-life)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-raspi-5.4
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc5)
bionic
Released (5.4.0-1029.32~18.04.1)
jammy Does not exist

linux-riscv
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Not vulnerable
(5.11.0-1007.7)
groovy
Released (5.8.0-17.19)
hirsute Not vulnerable
(5.11.0-1004.4)
upstream
Released (5.10~rc5)
focal Ignored
(was needed now end-of-life)
jammy Not vulnerable
(5.13.0-1004.4)
linux-snapdragon
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc5)
xenial
Released (4.4.0-1149.159)
bionic
Released (4.15.0-1096.105)
jammy Does not exist

linux-hwe-5.8
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

focal
Released (5.8.0-44.50~20.04.1)
groovy Does not exist

hirsute Does not exist

upstream
Released (5.10~rc5)
jammy Does not exist

linux-gke-5.4
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-1036.38~18.04.1)
focal Does not exist

groovy Does not exist

hirsute Does not exist

upstream
Released (5.10~rc5)
jammy Does not exist

linux-gkeop-5.4
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-1010.11~18.04.1)
focal Does not exist

groovy Does not exist

hirsute Does not exist

upstream
Released (5.10~rc5)
jammy Does not exist

linux-dell300x
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

upstream
Released (5.10~rc5)
bionic
Released (4.15.0-1012.16)
jammy Does not exist

linux-oem-5.10
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal Not vulnerable
(5.10.0-1008.9)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-gkeop
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

upstream
Released (5.10~rc5)
focal
Released (5.4.0-1010.11)
jammy Does not exist

linux-gke
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Ignored
(reached end of standard support)
bionic Does not exist

focal
Released (5.4.0-1036.38)
groovy Does not exist

hirsute Does not exist

upstream
Released (5.10~rc5)
jammy Not vulnerable
(5.15.0-1002.2)
linux-ibm
Launchpad, Ubuntu, Debian
impish Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

focal Not vulnerable
(5.4.0-1003.4)
upstream
Released (5.10~rc5)
jammy Not vulnerable
(5.15.0-1002.2)
linux-gcp-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.11.0-1009.10~20.04.1)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-oem-5.14
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.14.0-1004.4)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-intel-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc5)
jammy Does not exist

linux-azure-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1009.10~20.04.2)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-hwe-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-21.21~20.04.1)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-aws-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable
(5.13.0-1008.9~20.04.2)
impish Does not exist

upstream
Released (5.10~rc5)
jammy Does not exist

linux-fips
Launchpad, Ubuntu, Debian
trusty Does not exist

bionic Does not exist

focal Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc5)
xenial Not vulnerable
(4.4.0-1073.79)
jammy Does not exist

linux-oracle-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1011.13~20.04.2)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-gcp-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1008.9~20.04.3)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-ibm-5.4
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

focal Does not exist

impish Does not exist

bionic Not vulnerable
(5.4.0-1010.11~18.04.2)
upstream
Released (5.10~rc5)
jammy Does not exist

linux-azure-fde
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Needed

upstream
Released (5.10~rc5)
jammy Does not exist

linux-lowlatency
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable

upstream Needs triage

linux-oem-5.17
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable

upstream Needs triage