Your submission was sent successfully! Close

CVE-2020-25656

Published: 2 December 2020

A flaw was found in the Linux kernel. A use-after-free was found in the way the console subsystem was using ioctls KDGKBSENT and KDSKBSENT. A local user could use this flaw to get read memory access out of bounds. The highest threat from this vulnerability is to data confidentiality.

From the Ubuntu Security Team

It was discovered that the console keyboard driver in the Linux kernel contained a race condition. A local attacker could use this to expose sensitive information (kernel memory).

Priority

Low

CVSS 3 base score: 4.1

Status

Package Release Status
linux-aws-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal Not vulnerable
(5.8.0-1035.37~20.04.1)
upstream
Released (5.10~rc2)
impish Does not exist

jammy Does not exist

kinetic Does not exist

linux-azure-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal Not vulnerable
(5.8.0-1033.35~20.04.1)
upstream
Released (5.10~rc2)
impish Does not exist

jammy Does not exist

kinetic Does not exist

linux-gcp-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal Not vulnerable
(5.8.0-1032.34~20.04.1)
upstream
Released (5.10~rc2)
impish Does not exist

jammy Does not exist

kinetic Does not exist

linux-oracle-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal Not vulnerable
(5.8.0-1031.32~20.04.2)
upstream
Released (5.10~rc2)
impish Does not exist

jammy Does not exist

kinetic Does not exist

linux-riscv-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

upstream
Released (5.10~rc2)
focal
Released (5.8.0-17.19~20.04.1)
impish Does not exist

jammy Does not exist

kinetic Does not exist

linux-hwe-5.11
Launchpad, Ubuntu, Debian
focal Not vulnerable
(5.11.0-22.23~20.04.1)
upstream
Released (5.10~rc2)
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

linux-riscv-5.11
Launchpad, Ubuntu, Debian
focal Not vulnerable
(5.11.0-1015.16~20.04.1)
upstream
Released (5.10~rc2)
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

linux-oem-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable
(5.13.0-1009.10)
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

jammy Does not exist

kinetic Does not exist

linux-aws-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.11.0-1009.9~20.04.2)
upstream
Released (5.10~rc2)
jammy Does not exist

kinetic Does not exist

linux-azure-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.11.0-1007.7~20.04.2)
upstream
Released (5.10~rc2)
jammy Does not exist

kinetic Does not exist

linux-oracle-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable
(5.11.0-1008.8~20.04.1)
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

jammy Does not exist

kinetic Does not exist

linux-bluefield
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

upstream
Released (5.10~rc2)
focal
Released (5.4.0-1011.14)
impish Does not exist

jammy Does not exist

kinetic Does not exist

linux
Launchpad, Ubuntu, Debian
precise Ignored
(was needs-triage ESM criteria)
hirsute Not vulnerable
(5.10.0-14.15)
impish Not vulnerable
(5.11.0-16.17)
trusty Ignored
(was needed ESM criteria)
upstream
Released (5.10~rc2)
xenial
Released (4.4.0-198.230)
bionic
Released (4.15.0-129.132)
focal
Released (5.4.0-59.65)
groovy
Released (5.8.0-44.50)
jammy Not vulnerable
(5.13.0-19.19)
kinetic Not vulnerable
(5.15.0-25.25)
Patches:
Introduced by

1da177e4c3f41524e886b7f1b8a0c1fc7321cac2

Fixed by 82e61c3909db51d91b9d3e2071557b6435018b80
linux-aws
Launchpad, Ubuntu, Debian
trusty
Released (4.4.0-1083.87)
impish Not vulnerable
(5.11.0-1006.6)
xenial
Released (4.4.0-1119.133)
bionic
Released (4.15.0-1091.96)
focal
Released (5.4.0-1034.35)
groovy
Released (5.8.0-1024.26)
hirsute Not vulnerable
(5.8.0-1025.27+21.04.1)
upstream
Released (5.10~rc2)
precise Does not exist

jammy Not vulnerable
(5.13.0-1005.6)
kinetic Not vulnerable
(5.15.0-1004.6)
linux-aws-5.0
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc2)
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-aws-5.3
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc2)
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-azure
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
upstream
Released (5.10~rc2)
xenial
Released (4.15.0-1103.114~16.04.1)
impish Not vulnerable
(5.11.0-1004.4)
trusty
Released (4.15.0-1103.114~14.04.1)
hirsute Not vulnerable
(5.8.0-1024.26+21.04.1)
precise Does not exist

focal
Released (5.4.0-1035.36)
groovy
Released (5.8.0-1023.25)
jammy Not vulnerable
(5.13.0-1006.7)
kinetic Not vulnerable
(5.15.0-1003.4)
linux-azure-5.3
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-azure-edge
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-gcp
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
groovy
Released (5.8.0-1023.24)
hirsute Not vulnerable
(5.8.0-1024.25+21.04.1)
upstream
Released (5.10~rc2)
xenial
Released (4.15.0-1091.104~16.04.1)
impish Not vulnerable
(5.11.0-1006.6)
focal
Released (5.4.0-1033.35)
precise Does not exist

trusty Does not exist

jammy Not vulnerable
(5.13.0-1005.6)
kinetic Not vulnerable
(5.15.0-1003.6)
linux-gcp-5.3
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-gcp-edge
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-hwe-edge
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc2)
precise Does not exist

trusty Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

xenial Ignored
(was needs-triage ESM criteria)
kinetic Does not exist

linux-lts-trusty
Launchpad, Ubuntu, Debian
precise Ignored
(was needs-triage ESM criteria)
hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc2)
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-oem
Launchpad, Ubuntu, Debian
xenial Ignored
(was needs-triage now end-of-life)
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

precise Does not exist

trusty Does not exist

bionic Ignored
(was pending [4.15.0-1104.115] now end-of-life)
focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-oracle-5.0
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-oracle-5.3
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-raspi2
Launchpad, Ubuntu, Debian
focal Ignored
(was needs-triage now end-of-life)
hirsute Does not exist

bionic
Released (4.15.0-1077.82)
upstream
Released (5.10~rc2)
impish Does not exist

xenial
Released (4.4.0-1143.153)
precise Does not exist

trusty Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc2)
precise Does not exist

trusty Does not exist

xenial
Released (4.15.0-129.132~16.04.1)
bionic Ignored
(was needed now end-of-life)
focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-hwe-5.4
Launchpad, Ubuntu, Debian
hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc2)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-59.65~18.04.1)
focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
hirsute Does not exist

impish Does not exist

trusty
Released (4.4.0-198.230~14.04.1)
upstream
Released (5.10~rc2)
precise Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-aws-5.4
Launchpad, Ubuntu, Debian
hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc2)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-1034.35~18.04.1)
focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-aws-hwe
Launchpad, Ubuntu, Debian
hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc2)
precise Does not exist

trusty Does not exist

xenial
Released (4.15.0-1091.96~16.04.1)
bionic Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-azure-4.15
Launchpad, Ubuntu, Debian
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

bionic
Released (4.15.0-1103.114)
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-azure-5.4
Launchpad, Ubuntu, Debian
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

bionic
Released (5.4.0-1035.36~18.04.1)
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-gcp-4.15
Launchpad, Ubuntu, Debian
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

bionic
Released (4.15.0-1091.104)
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-gcp-5.4
Launchpad, Ubuntu, Debian
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

bionic
Released (5.4.0-1033.35~18.04.1)
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-gke-4.15
Launchpad, Ubuntu, Debian
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

bionic
Released (4.15.0-1077.82)
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-gke-5.0
Launchpad, Ubuntu, Debian
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Ignored
(was needed now end-of-life)
focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-gke-5.3
Launchpad, Ubuntu, Debian
hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc2)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Ignored
(was needed now end-of-life)
focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-oracle-5.4
Launchpad, Ubuntu, Debian
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

bionic
Released (5.4.0-1034.36~18.04.1)
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-oem-5.6
Launchpad, Ubuntu, Debian
hirsute Does not exist

focal
Released (5.6.0-1050.54)
upstream
Released (5.10~rc2)
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-oem-osp1
Launchpad, Ubuntu, Debian
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

bionic Ignored
(was needed now end-of-life)
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-raspi2-5.3
Launchpad, Ubuntu, Debian
hirsute Does not exist

bionic Ignored
(was needed now end-of-life)
upstream
Released (5.10~rc2)
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-raspi-5.4
Launchpad, Ubuntu, Debian
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

bionic
Released (5.4.0-1026.29~18.04.1)
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-snapdragon
Launchpad, Ubuntu, Debian
hirsute Does not exist

upstream
Released (5.10~rc2)
impish Does not exist

xenial
Released (4.4.0-1147.157)
bionic
Released (4.15.0-1094.103)
precise Does not exist

trusty Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

kinetic Does not exist

linux-oracle
Launchpad, Ubuntu, Debian
groovy
Released (5.8.0-1021.22)
hirsute Not vulnerable
(5.8.0-1022.23+21.04.1)
upstream
Released (5.10~rc2)
impish Not vulnerable
(5.11.0-1005.5)
bionic
Released (4.15.0-1062.68)
focal
Released (5.4.0-1034.36)
xenial
Released (4.15.0-1062.68~16.04.1)
precise Does not exist

trusty Does not exist

jammy Not vulnerable
(5.13.0-1008.10)
kinetic Not vulnerable
(5.15.0-1002.4)
linux-raspi
Launchpad, Ubuntu, Debian
focal
Released (5.4.0-1026.29)
groovy
Released (5.8.0-1016.19)
hirsute Not vulnerable
(5.11.0-1003.3)
upstream
Released (5.10~rc2)
impish Not vulnerable
(5.11.0-1007.7)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Not vulnerable
(5.13.0-1008.9)
kinetic Not vulnerable
(5.15.0-1005.5)
linux-riscv
Launchpad, Ubuntu, Debian
groovy
Released (5.8.0-17.19)
hirsute Not vulnerable
(5.11.0-1004.4)
upstream
Released (5.10~rc2)
impish Not vulnerable
(5.11.0-1007.7)
focal
Released (5.4.0-40.45)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Not vulnerable
(5.13.0-1004.4)
kinetic Not vulnerable
(5.15.0-1007.7)
linux-kvm
Launchpad, Ubuntu, Debian
impish Not vulnerable
(5.11.0-1006.6)
hirsute Not vulnerable
(5.8.0-1020.22+21.04.1)
upstream
Released (5.10~rc2)
precise Does not exist

trusty Does not exist

xenial
Released (4.4.0-1085.94)
bionic
Released (4.15.0-1082.84)
focal
Released (5.4.0-1031.32)
groovy
Released (5.8.0-1019.21)
jammy Not vulnerable
(5.13.0-1004.4)
kinetic Not vulnerable
(5.15.0-1004.4)
linux-hwe-5.8
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

focal
Released (5.8.0-44.50~20.04.1)
groovy Does not exist

hirsute Does not exist

upstream
Released (5.10~rc2)
jammy Does not exist

kinetic Does not exist

linux-gke-5.4
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

upstream
Released (5.10~rc2)
bionic
Released (5.4.0-1033.35~18.04.1)
jammy Does not exist

kinetic Does not exist

linux-gkeop-5.4
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic
Released (5.4.0-1008.9~18.04.1)
upstream
Released (5.10~rc2)
jammy Does not exist

kinetic Does not exist

linux-dell300x
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

upstream
Released (5.10~rc2)
bionic
Released (4.15.0-1010.14)
jammy Does not exist

kinetic Does not exist

linux-oem-5.10
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal Not vulnerable
(5.10.0-1008.9)
upstream
Released (5.10~rc2)
jammy Does not exist

kinetic Does not exist

linux-gkeop
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal Not vulnerable
(5.4.0-1008.9)
upstream
Released (5.10~rc2)
jammy Needs triage

kinetic Does not exist

linux-gke
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

jammy Not vulnerable
(5.15.0-1002.2)
focal Not vulnerable
(5.4.0-1033.35)
upstream
Released (5.10~rc2)
xenial Ignored
(reached end of standard support)
kinetic Does not exist

linux-ibm
Launchpad, Ubuntu, Debian
impish Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

focal Not vulnerable
(5.4.0-1003.4)
upstream
Released (5.10~rc2)
jammy Not vulnerable
(5.15.0-1002.2)
kinetic Not vulnerable
(5.15.0-1002.2)
linux-gcp-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.11.0-1009.10~20.04.1)
upstream
Released (5.10~rc2)
jammy Does not exist

kinetic Does not exist

linux-oem-5.14
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.14.0-1004.4)
upstream
Released (5.10~rc2)
jammy Does not exist

kinetic Does not exist

linux-intel-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable
(5.13.0-1007.7)
hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc2)
jammy Does not exist

kinetic Does not exist

linux-azure-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1009.10~20.04.2)
upstream
Released (5.10~rc2)
jammy Does not exist

kinetic Does not exist

linux-hwe-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-21.21~20.04.1)
upstream
Released (5.10~rc2)
jammy Does not exist

kinetic Does not exist

linux-aws-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable
(5.13.0-1008.9~20.04.2)
impish Does not exist

upstream
Released (5.10~rc2)
jammy Does not exist

kinetic Does not exist

linux-fips
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Ignored
(out of standard support)
bionic Does not exist

focal Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.10~rc2)
jammy Does not exist

kinetic Does not exist

linux-oracle-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1011.13~20.04.2)
upstream
Released (5.10~rc2)
jammy Does not exist

kinetic Does not exist

linux-gcp-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1008.9~20.04.3)
upstream
Released (5.10~rc2)
jammy Does not exist

kinetic Does not exist

linux-ibm-5.4
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

focal Does not exist

impish Does not exist

bionic Not vulnerable
(5.4.0-1010.11~18.04.2)
upstream
Released (5.10~rc2)
jammy Does not exist

kinetic Does not exist

linux-azure-fde
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Needed

upstream
Released (5.10~rc2)
jammy Needs triage

kinetic Does not exist

linux-lowlatency
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable
(5.15.0-22.22)
upstream
Released (5.10~rc2)
kinetic Not vulnerable
(5.15.0-24.24)
linux-oem-5.17
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable
(5.17.0-1003.3)
upstream
Released (5.10~rc2)
kinetic Not vulnerable
(5.17.0-1003.3)
linux-intel-iotg
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable

upstream Needs triage

kinetic Does not exist

linux-intel-iotg-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

impish Does not exist

jammy Does not exist

upstream Needs triage

kinetic Does not exist

linux-lowlatency-hwe-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

upstream Needs triage

kinetic Does not exist

linux-hwe-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

upstream Needs triage

kinetic Does not exist

linux-aws-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

jammy Does not exist

upstream Needs triage

focal Not vulnerable

kinetic Does not exist

linux-gcp-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

upstream Needs triage

kinetic Does not exist

linux-gke-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

upstream Needs triage

kinetic Does not exist

linux-azure-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

upstream Needs triage

kinetic Does not exist

linux-oracle-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

upstream Needs triage

kinetic Does not exist

linux-azure-fde-5.15
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

jammy Does not exist

kinetic Does not exist

upstream Needs triage