Your submission was sent successfully! Close

CVE-2020-25639

Published: 4 March 2021

A NULL pointer dereference flaw was found in the Linux kernel's GPU Nouveau driver functionality in versions prior to 5.12-rc1 in the way the user calls ioctl DRM_IOCTL_NOUVEAU_CHANNEL_ALLOC. This flaw allows a local user to crash the system.

From the Ubuntu security team

It was discovered that the Nouveau GPU driver in the Linux kernel did not properly handle error conditions in some situations. A local attacker could use this to cause a denial of service (system crash).

Priority

Low

CVSS 3 base score: 4.4

Status

Package Release Status
linux-aws-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal Not vulnerable
(5.8.0-1035.37~20.04.1)
upstream
Released (5.12~rc1)
impish Does not exist

jammy Does not exist

linux-azure-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal Not vulnerable
(5.8.0-1033.35~20.04.1)
upstream
Released (5.12~rc1)
impish Does not exist

jammy Does not exist

linux-gcp-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal Not vulnerable
(5.8.0-1032.34~20.04.1)
upstream
Released (5.12~rc1)
impish Does not exist

jammy Does not exist

linux-oracle-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal Not vulnerable
(5.8.0-1031.32~20.04.2)
upstream
Released (5.12~rc1)
impish Does not exist

jammy Does not exist

linux-riscv-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
focal
Released (5.8.0-25.27~20.04.1)
impish Does not exist

jammy Does not exist

linux-hwe-5.11
Launchpad, Ubuntu, Debian
focal Not vulnerable
(5.11.0-22.23~20.04.1)
upstream
Released (5.12~rc1)
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

linux-riscv-5.11
Launchpad, Ubuntu, Debian
focal Not vulnerable
(5.11.0-1015.16~20.04.1)
upstream
Released (5.12~rc1)
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

linux-oem-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable
(5.13.0-1009.10)
hirsute Does not exist

upstream
Released (5.12~rc1)
impish Does not exist

jammy Does not exist

linux-aws-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable
(5.11.0-1009.9~20.04.2)
hirsute Does not exist

upstream
Released (5.12~rc1)
impish Does not exist

jammy Does not exist

linux-azure-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.11.0-1007.7~20.04.2)
upstream
Released (5.12~rc1)
jammy Does not exist

linux-oracle-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.11.0-1008.8~20.04.1)
upstream
Released (5.12~rc1)
jammy Does not exist

linux-bluefield
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
focal
Released (5.4.0-1011.14)
impish Does not exist

jammy Does not exist

linux
Launchpad, Ubuntu, Debian
impish Not vulnerable
(5.11.0-16.17)
upstream
Released (5.12~rc1)
focal
Released (5.4.0-73.82)
hirsute Not vulnerable
(5.11.0-13.14)
precise Ignored
(was needs-triage ESM criteria)
trusty Not vulnerable
(3.11.0-12.19)
xenial Not vulnerable
(4.4.0-2.16)
bionic Not vulnerable
(4.13.0-16.19)
groovy
Released (5.8.0-53.60)
jammy Not vulnerable
(5.13.0-19.19)
linux-hwe
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Not vulnerable
(4.8.0-39.42~16.04.1)
bionic Ignored
(was needed now end-of-life)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-hwe-5.4
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-73.82~18.04.1)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-hwe-edge
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Ignored
(was needs-triage now end-of-life)
bionic Ignored
(was needs-triage now end-of-life)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-lts-trusty
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Ignored
(was needs-triage ESM criteria)
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Not vulnerable
(4.4.0-13.29~14.04.1)
xenial Does not exist

bionic Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

linux-kvm
Launchpad, Ubuntu, Debian
impish Not vulnerable
(5.11.0-1006.6)
upstream
Released (5.12~rc1)
hirsute Not vulnerable
(5.11.0-1003.3)
precise Does not exist

trusty Does not exist

xenial Not vulnerable
(4.4.0-1004.9)
bionic Not vulnerable
(4.15.0-1002.2)
focal
Released (5.4.0-1039.40)
groovy
Released (5.8.0-1027.29)
jammy Not vulnerable
(5.13.0-1004.4)
linux-aws
Launchpad, Ubuntu, Debian
impish Not vulnerable
(5.11.0-1006.6)
upstream
Released (5.12~rc1)
hirsute Not vulnerable
(5.11.0-1003.3)
precise Does not exist

trusty Not vulnerable
(4.4.0-1002.2)
xenial Not vulnerable
(4.4.0-1001.10)
bionic Not vulnerable
(4.15.0-1001.1)
focal
Released (5.4.0-1048.50)
groovy
Released (5.8.0-1033.35)
jammy Not vulnerable
(5.13.0-1005.6)
linux-aws-5.0
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Ignored
(was needs-triage now end-of-life)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-aws-5.3
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Ignored
(was needs-triage now end-of-life)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-aws-5.4
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-1048.50~18.04.1)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-aws-hwe
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Not vulnerable
(4.15.0-1030.31~16.04.1)
bionic Does not exist

focal Does not exist

groovy Does not exist

jammy Does not exist

linux-azure
Launchpad, Ubuntu, Debian
impish Not vulnerable
(5.11.0-1004.4)
upstream
Released (5.12~rc1)
hirsute Not vulnerable
(5.11.0-1002.2)
precise Does not exist

trusty Not vulnerable
(4.15.0-1023.24~14.04.1)
xenial Not vulnerable
(4.11.0-1009.9)
bionic Ignored
(was needs-triage now end-of-life)
focal
Released (5.4.0-1047.49)
groovy
Released (5.8.0-1032.34)
jammy Not vulnerable
(5.13.0-1006.7)
linux-azure-4.15
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Not vulnerable
(4.15.0-1082.92)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-azure-5.3
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Ignored
(was needs-triage now end-of-life)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-azure-5.4
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-1047.49~18.04.1)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-azure-edge
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Ignored
(was needs-triage now end-of-life)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-gcp
Launchpad, Ubuntu, Debian
impish Not vulnerable
(5.11.0-1006.6)
upstream
Released (5.12~rc1)
hirsute Not vulnerable
(5.11.0-1003.3)
precise Does not exist

trusty Does not exist

xenial Not vulnerable
(4.10.0-1004.4)
bionic Ignored
(was needs-triage now end-of-life)
focal
Released (5.4.0-1043.46)
groovy
Released (5.8.0-1031.32)
jammy Not vulnerable
(5.13.0-1005.6)
linux-gcp-4.15
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Not vulnerable
(4.15.0-1071.81)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-gcp-5.3
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Ignored
(was needs-triage now end-of-life)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-gcp-5.4
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-1043.46~18.04.1)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-gcp-edge
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Ignored
(was needs-triage now end-of-life)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-gke-4.15
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Not vulnerable
(4.15.0-1030.32)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-gke-5.0
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Not vulnerable
(5.0.0-1011.11~18.04.1)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-gke-5.3
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Ignored
(was needed now end-of-life)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-oracle
Launchpad, Ubuntu, Debian
impish Not vulnerable
(5.11.0-1005.5)
upstream
Released (5.12~rc1)
hirsute Not vulnerable
(5.11.0-1002.2)
precise Does not exist

trusty Does not exist

xenial Not vulnerable
(4.15.0-1007.9~16.04.1)
bionic Not vulnerable
(4.15.0-1007.9)
focal
Released (5.4.0-1045.49)
groovy
Released (5.8.0-1029.30)
jammy Not vulnerable
(5.13.0-1008.10)
linux-oracle-5.0
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Ignored
(was needs-triage now end-of-life)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-oracle-5.3
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Ignored
(was needs-triage now end-of-life)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-oracle-5.4
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-1044.47~18.04.1)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-oem
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Ignored
(was needs-triage now end-of-life)
bionic Not vulnerable
(4.15.0-1002.3)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-oem-5.6
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(was needed now end-of-life)
groovy Does not exist

jammy Does not exist

linux-oem-osp1
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Not vulnerable
(5.0.0-1010.11)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-raspi
Launchpad, Ubuntu, Debian
impish Not vulnerable
(5.11.0-1007.7)
upstream
Released (5.12~rc1)
hirsute Not vulnerable
(5.11.0-1004.4)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

focal
Released (5.4.0-1035.38)
groovy
Released (5.8.0-1024.27)
jammy Not vulnerable
(5.13.0-1008.9)
linux-raspi2
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Not vulnerable
(4.2.0-1013.19)
bionic Not vulnerable
(4.13.0-1005.5)
focal Ignored
(was needs-triage now end-of-life)
groovy Does not exist

jammy Does not exist

linux-raspi2-5.3
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Ignored
(was needed now end-of-life)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-raspi-5.4
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-1035.38~18.04.1)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-riscv
Launchpad, Ubuntu, Debian
impish Not vulnerable
(5.11.0-1007.7)
upstream
Released (5.12~rc1)
hirsute Not vulnerable
(5.11.0-1004.4)
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(was needed now end-of-life)
groovy
Released (5.8.0-25.27)
jammy Not vulnerable
(5.13.0-1004.4)
linux-snapdragon
Launchpad, Ubuntu, Debian
impish Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
precise Does not exist

trusty Does not exist

xenial Not vulnerable
(4.4.0-1013.15)
bionic Not vulnerable
(4.4.0-1077.82)
focal Does not exist

groovy Does not exist

jammy Does not exist

linux-hwe-5.8
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

focal
Released (5.8.0-53.60~20.04.1)
groovy Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
jammy Does not exist

linux-gke-5.4
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-1043.45~18.04.1)
focal Does not exist

groovy Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
jammy Does not exist

linux-gkeop-5.4
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-1015.16~18.04.1)
focal Does not exist

groovy Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
jammy Does not exist

linux-dell300x
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Not vulnerable
(4.15.0-1005.8)
upstream
Released (5.12~rc1)
jammy Does not exist

linux-oem-5.10
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

focal
Released (5.10.0-1021.22)
groovy Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
jammy Does not exist

linux-gkeop
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

focal
Released (5.4.0-1015.16)
groovy Does not exist

hirsute Does not exist

upstream
Released (5.12~rc1)
jammy Does not exist

linux-gke
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal
Released (5.4.0-1043.45)
jammy Not vulnerable
(5.15.0-1002.2)
upstream
Released (5.12~rc1)
xenial Ignored
(reached end of standard support)
linux-ibm
Launchpad, Ubuntu, Debian
impish Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

focal Not vulnerable
(5.4.0-1003.4)
upstream
Released (5.12~rc1)
jammy Not vulnerable
(5.15.0-1002.2)
linux-gcp-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.11.0-1009.10~20.04.1)
upstream
Released (5.12~rc1)
jammy Does not exist

linux-oem-5.14
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.14.0-1004.4)
upstream
Released (5.12~rc1)
jammy Does not exist

linux-intel-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

hirsute Does not exist

impish Does not exist

upstream
Released (5.12~rc1)
jammy Does not exist

linux-azure-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1009.10~20.04.2)
upstream
Released (5.12~rc1)
jammy Does not exist

linux-hwe-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-21.21~20.04.1)
upstream
Released (5.12~rc1)
jammy Does not exist

linux-aws-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1008.9~20.04.2)
upstream
Released (5.12~rc1)
jammy Does not exist

linux-fips
Launchpad, Ubuntu, Debian
trusty Does not exist

bionic Does not exist

focal Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.12~rc1)
xenial Not vulnerable
(4.4.0-1073.79)
jammy Does not exist

linux-oracle-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1011.13~20.04.2)
upstream
Released (5.12~rc1)
jammy Does not exist

linux-gcp-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1008.9~20.04.3)
upstream
Released (5.12~rc1)
jammy Does not exist

linux-ibm-5.4
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

focal Does not exist

impish Does not exist

bionic Not vulnerable
(5.4.0-1010.11~18.04.2)
upstream
Released (5.12~rc1)
jammy Does not exist

linux-azure-fde
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.4.0-1063.66+cvm2.2)
upstream
Released (5.12~rc1)
jammy Does not exist

linux-lowlatency
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable

upstream Needs triage

linux-oem-5.17
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable

upstream Needs triage